No titlebar context menu in after a right-click

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: twocables, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130726 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130726040203

Steps to reproduce:

Right-click the titlebar


Actual results:

Nothing


Expected results:

One of the following two context menus should have appeared, depending on if I right-click high or right-click low on the titlebar:

1. The system context menu (Restore, Move, Size, Minimize, Maximize, Close)
2. The context menu containing the options for Menu Bar and Bookmarks Toolbar (and Customize)

Note: this began happening after the most recent update for 2013-7-26. Previously, depending on where I right-clicked on the titlebar, I could get either the system menu or the Firefox menu. Now I get nothing.

Another note: I have 11 tabs open. If I right-click in the tiny space above the empty space on the far right (immediately to the left of the Minimize, Maximize, Close buttons), then I can get the system menu or the Firefox menu depending on where I click. However, having just 1 tab open results in not getting a menu at ALL no matter where I right-click.

Final note: The convenience is, I can just right-click anywhere on the titlebar and choose either 'Close' or just press 'C' (my left hand is usually on home row). I know about Alt+F4 and I do use that from time to time, but when I'm getting ready to close Firefox (UX Nightly), my right-hand is usually on the mouse. So, right-clicking the titlebar and choosing Close or pressing C is far more convenient. It's even more convenient than aiming at the red X. Although, if this is an intentional design change that will not be reverted, then I suppose that I could just get used to middle-clicking the Taskbar preview instead because my preferred setting is to have just one preview instead of one for each tab.

Still, I can't imagine that I'm the only one who closes windows by right-clicking the titlebar and choosing Close or pressing C. I mean, by not having this context menu, it instantly becomes inconsistent with Windows. Furthermore, the Firefox context menu needs to be there as well.

Comment 1

4 years ago
/// Another note: I have 11 tabs open. If I right-click in the tiny space above the empty space on the far right (immediately to the left of the Minimize, Maximize, Close buttons), then I can get the system menu or the Firefox menu depending on where I click. However, having just 1 tab open results in not getting a menu at ALL no matter where I right-click. ///

Hi,
i tried this one, but i am not facing this issue. could you please post the screenshot
(Reporter)

Comment 2

4 years ago
(In reply to invent from comment #1)
> /// Another note: I have 11 tabs open. If I right-click in the tiny space
> above the empty space on the far right (immediately to the left of the
> Minimize, Maximize, Close buttons), then I can get the system menu or the
> Firefox menu depending on where I click. However, having just 1 tab open
> results in not getting a menu at ALL no matter where I right-click. ///
> 
> Hi,
> i tried this one, but i am not facing this issue. could you please post the
> screenshot

To simplify it: right-click directly above any tab. So, even with 1 tab open, right-click directly above it. When I do this, I get nothing. If I right-click the title bar over to the right where NO tabs are, then I get one of the two context menus that I expect, depending on where I right-click.
(Reporter)

Comment 3

4 years ago
I started UX in a new profile and there's a slight change. If I right-click high enough above a tab, then I get the Windows context menu. If I right-click slightly lower on the titlebar (right above a tab), then I get nothing when I should be getting the Firefox context menu for the toolbar.

So, even though it kind of works with a fresh new profile, it's still broken. Even right-clicking directly above a tab should produce either of these 2 context menus.

With 1 tab open, I can easily get either of these 2 context menus by right-clicking elsewhere on the titlebar instead of right-clicking above a tab.

Comment 4

4 years ago
well, i got the idea and it works fine, i get two kinds of menus on the right click depending on where i click. i feel like it works fine.

i am on Firefox Aurora 24.

please find the attachments screenshots.

Comment 5

4 years ago
Created attachment 783169 [details]
right-click1.jpg

Comment 6

4 years ago
Created attachment 783170 [details]
right-click2.jpg
(Reporter)

Comment 7

4 years ago
This for this UX Nightly.

http://people.mozilla.org/~jwein/ux-nightly/
(Reporter)

Comment 8

4 years ago
I meant "this is for UX Nightly".

Comment 9

4 years ago
oops, sorry, my mistake. 
installing the UX, let me check this one again..

Comment 10

4 years ago
well, i installed the UX from this link:
http://people.mozilla.org/~jwein/ux-nightly/

and when currently i am having:
Firefox Aurora
24.0a2 (2013-07-30)
Aurora is up to date.

am i using the correct UX?
(Reporter)

Comment 11

4 years ago
You (In reply to invent from comment #10)
> well, i installed the UX from this link:
> http://people.mozilla.org/~jwein/ux-nightly/
> 
> and when currently i am having:
> Firefox Aurora
> 24.0a2 (2013-07-30)
> Aurora is up to date.
> 
> am i using the correct UX?

Close Aurora first before opening UX. It uses your default profile.

For the future, this is the way it is for all of them. That is, UX Nightly, Nightly, Aurora, Beta, and the stable release. They all use the same profile, one must be closed before opening another. Otherwise, you just get a new window of the one you already have open.
(Reporter)

Comment 12

4 years ago
I almost forgot:

When you right-click right above a tab, utilize the entire space. The closest area above the tab gets no context menu while closer to the top DOES get one (at least with a fresh and clean profile).

In regular Nightly, Aurora, Beta, and the stable release, it doesn't matter where I right-click above a tab: I always get the Windows context menu which is what I'm accustomed to (which is what I prefer).
(Reporter)

Comment 13

4 years ago
I was wrong. In the regular Nightly, it's the same problem for me as I get in the regular Nightly.

So, this only affects UX Nightly and Nightly.

Comment 14

4 years ago
Strange!!!
i am on the UX and with a single tab open. when i right click above the tab, on any empty space right side to the tab, i get the menu(attachment "UX-right-click-menu").

but on this particular area(near middle of the screen) i get the "restore menu"(attachment "UX-restore-menu")

Comment 15

4 years ago
Created attachment 783186 [details]
UX-restore-menu.png

Comment 16

4 years ago
Created attachment 783187 [details]
UX-right-click-menu.png
(Reporter)

Comment 17

4 years ago
Now, right-click on top of a tab. Not only above it, but right-click in that very tiny space directly above a tab. It's the part that's as close to the tab as possible without actually right-clicking the tab itself.

You just discovered what I was telling you: you get the normal context menus when right-clicking elsewhere, but you don't get the Windows context menu when right-clicking above a tab - at least when you get close enough to it. For me though, I think the extension Aero Window Title is killing the Windows context menu entirely right above tabs but NOT in the empty space to the right.

I'll keep testing to see if this is true.
Duplicate of this bug: 904052
Hi twocables, Does this issue still happen when you start Firefox with add-ons turned off? In the duplicate issue (bug 904052) you mention the add-on Aero Window Title.  It sounds like the bug may be in that add-on. Thanks!
(Reporter)

Comment 20

4 years ago
This is now affecting Nightly and Aurora. I think this happens when the browser becomes version 25. At first, it only affected UX Nightly. So, I switched to Nightly and then it later affected that after one of the updates, and I'm assuming that it was when it became version 25. Then I switched to Aurora, and again, it began affected Aurora after one of the updates, and this time I'm pretty sure it was when it became version 25.

So, I did a little test with Aurora. As before with UX Nightly, I added "-p" and started with a new Profile. As before, I could right-click above the one (and only) tab and get the expected results - unless I right-clicked down too close to the tab. Note: I can right-click "too close" to the one (and only) open tab in Firefox 22 (and now Firefox 23) and I still get the expected results, but not so in Aurora/Nightly/UX Nightly 25. In 25, I get nothing. However, I can get the expected results in Aurora if I right-click on the titlebar where there is no tab below.

Except, this time I did something different: I opened up several tabs (probably 8-10 tabs). When I did this, I found that I was once again NOT getting the expected results. Remember, before doing this I only had 1 tab open and I could get the expected results if I right-clicked the titlebar high enough above that only tab. Now with several tabs open, I get nothing at all. So then I closed all the tabs and to my surprise, I was STILL getting nothing. I then restarted Aurora and it was still broken. So then I deleted the profile and created a new one. As expected, it put me at the beginning and I was able to do all of this all over again and get the same results.

Therefore, I am concluding that this has nothing to do with Aero Window Title (or any extension for that matter).
(Reporter)

Comment 21

4 years ago
No, I was wrong. That doesn't begin happening when I open several tabs; it happens when I move or re-size the window. So, when I start UX Nightly/Nightly/Aurora 25 with a new profile, I get the expected results until I move or re-size the window.

However, even so: there's a small space above the tab(s) where I get nothing. In Firefox 23 and earlier versions, I get the expected results.
(Reporter)

Comment 22

4 years ago
OH WOW. I just discovered something that could lead to solving this bug. It's FAR simpler than I thought:

The right-clickable area of the titlebar doesn't move when you move the titlebar in one way or another. It just stays at the top of the screen in the normal position for a maximized window. Therefore, just do whatever it takes to lower the titlebar maybe a half an inch or so. That's all that's needed. You can lower it by re-sizing downward, or you can lower it by moving the entire window down. You can move it all the way to the bottom of your monitor if you want, but all that's really needed is a tiny amount.

Also, take notice of this: move it just a few pixels at a time (move it slowly and gradually, right-clicking all over the titlebar's vertical space in between each tiny move), and you'll eventually begin noticing that the right-clickable area on the titlebar shrinks accordingly. After lowering the titlebar by a few pixels at a time by either re-sizing downward or by moving the whole window down, you can eventually reach a point where the only place where you can right-click is the very tip-top of the window where you get the re-size gripper. After this, if you move it down just a pixel or two, then you move it BELOW where the right-clickable area still is and therefore you can no longer right-click the titlebar or even the top re-size gripper.

In other words, the right-clickable area of the titlebar does NOT doesn't follow the window down when you either re-size it down or move the window down. It's as if it just stays behind because I can right-click again if I move the titlebar back to the top of the screen! So, I can get EXACTLY what I want (and am expecting) as long as the top of the window is as high up as it can possibly go - such as when the window is maximized or such as when double-clicking the top-side re-size gripper (Aero Snap). As soon as I slowly and gradually move the titlebar down in whichever way I choose, the right-clickable area shrinks upward accordingly.

This feels great. I figured it out. :) Now the hard part is, figuring out why this is happening. I mean, if the window is all the way up to the top either manually or with Aero Snap (or just maximized), then I get the same expected results that I'm still getting in Firefox 23. That means that I can even right-click directly on top of a tab (in that tiny space I mentioned) and still get the expected results. So you see, the reason I had that tiny space above a tab where I couldn't get any context menu at all is due to having the top of the window down just a little too far from the top-most part of my monitor (or "screen"). So, it's as if the top half of the titlebar was still in the right-clickable area, and the bottom half was BELOW it (outside of it). Crazy.

Dude. hehe :) This is great! Up until I discovered this, I thought it was some mysterious disappearing act of the titlebar's right-clickable area, but nope! It's just that the right-clickable area of the titlebar simply doesn't follow the window when moved down.

While typing up this comment, I discovered something else while considering the fact that the right-clickable area doesn't move when the window is moved: move the window all the way to the top as discussed to get the expected results. Except, now move the window side to side! Move it far right and then far left. When you move it far-right, move it so that the Minimize/Maximize/Close buttons are off-screen and then try right-clicking that area where these buttons would be with a maximized window. Then, move the window far-left and right-click where the Firefox button would normally be with a maximized window. In UX Nightly, this far-left trick doesn't apply because the right-clckable area of the titlebar is extended all the way to the left. However, of course, it definitely applies to the far-right trick.

What a great day this has become. lol :)
(Reporter)

Comment 23

4 years ago
I have one more comment to post! This has been fixed in both UX Nightly and Nightly! All that's left now is Aurora.
Re-summarizing to reflect the fact that is isn't UX Nightly specific anymore.

twocables, is this fixed everywhere now?
Flags: needinfo?(twocables)
Summary: No titlebar context menu in UX Nightly (can't right-click) → No titlebar context menu in after a right-click
(Reporter)

Comment 25

4 years ago
(In reply to Matthew N. [:MattN] (catching up on reviews) from comment #24)
> Re-summarizing to reflect the fact that is isn't UX Nightly specific anymore.
> 
> twocables, is this fixed everywhere now?

It seems to be.

Thank you for asking.
Flags: needinfo?(twocables)
Thanks for following-up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 27

4 years ago
You're welcome!
You need to log in before you can comment on or make changes to this bug.