Closed Bug 898588 Opened 6 years ago Closed 6 years ago

Enable HiDPI App chrome for Desktop Web Runtime

Categories

(Firefox Graveyard :: Webapp Runtime, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 25

People

(Reporter: potch, Assigned: marco)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Would be nice if running OWAs on HiDPI displays gave the nice crisp window dressing that one got when running Firefox.
Duplicate of bug 849448?
Quite likely! My search-fu didn't turn up anything. This is a slightly more general bug, but feel free to dupe.
Depends on: 849448
Is it just a matter of setting NSPrincipalClass and NSHighResolutionCapable in the Info.plist?
Attachment #783462 - Flags: review?(jfkthame)
Comment on attachment 783462 [details] [diff] [review]
enable_hidpi_webapps

Review of attachment 783462 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine, thanks!

(Actually, I think NSHighResolutionCapable might not even be needed; AFAICT it's not present in Firefox, for example. Just providing NSPrincipalClass should be sufficient. But declaring it as NSHighResolutionCapable seems like the right thing to do, anyhow.)
Attachment #783462 - Flags: review?(jfkthame) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/2466e891446d
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Keywords: checkin-needed
Version: 24 Branch → Trunk
No longer depends on: 849448
Duplicate of this bug: 849448
https://hg.mozilla.org/mozilla-central/rev/2466e891446d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Could anyone with a retina display verify?
Verified!
Blocks: osx-hidpi
Status: RESOLVED → VERIFIED
Duplicate of this bug: 913655
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.