Closed Bug 898592 Opened 7 years ago Closed 7 years ago

Tablet startup crash with new history tabs

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 895837

People

(Reporter: sriram, Assigned: sriram)

References

Details

(Keywords: crash, Whiteboard: abouthome-hackathon)

Crash Data

Attachments

(1 file)

E/GeckoAppShell( 3294): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
E/GeckoAppShell( 3294): java.lang.RuntimeException: You must supply layout attribute
E/GeckoAppShell( 3294): 	at org.mozilla.gecko.widget.IconTabWidget.<init>(IconTabWidget.java:33)
E/GeckoAppShell( 3294): 	at java.lang.reflect.Constructor.constructNative(Native Method)
E/GeckoAppShell( 3294): 	at java.lang.reflect.Constructor.newInstance(Constructor.java:417)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.createView(LayoutInflater.java:587)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:687)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:746)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.parseInclude(LayoutInflater.java:805)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:736)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:749)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:749)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:459)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:396)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:352)
E/GeckoAppShell( 3294): 	at org.mozilla.gecko.TabsPanel.<init>(TabsPanel.java:81)
E/GeckoAppShell( 3294): 	at java.lang.reflect.Constructor.constructNative(Native Method)
E/GeckoAppShell( 3294): 	at java.lang.reflect.Constructor.newInstance(Constructor.java:417)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.createView(LayoutInflater.java:587)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:687)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.rInflate(LayoutInflater.java:746)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:489)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:396)
E/GeckoAppShell( 3294): 	at android.view.LayoutInflater.inflate(LayoutInflater.java:352)
E/GeckoAppShell( 3294): 	at com.android.internal.policy.impl.PhoneWindow.setContentView(PhoneWindow.java:270)
E/GeckoAppShell( 3294): 	at android.app.Activity.setContentView(Activity.java:1881)
E/GeckoAppShell( 3294): 	at org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:1305)
E/GeckoAppShell( 3294): 	at org.mozilla.gecko.BrowserApp.onCreate(BrowserApp.java:391)
E/GeckoAppShell( 3294): 	at android.app.Activity.performCreate(Activity.java:5104)
E/GeckoAppShell( 3294): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1080)
E/GeckoAppShell( 3294): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2144)
E/GeckoAppShell( 3294): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2230)
E/GeckoAppShell( 3294): 	at android.app.ActivityThread.access$600(ActivityThread.java:141)
E/GeckoAppShell( 3294): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1234)
E/GeckoAppShell( 3294): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/GeckoAppShell( 3294): 	at android.os.Looper.loop(Looper.java:137)
E/GeckoAppShell( 3294): 	at android.app.ActivityThread.main(ActivityThread.java:5041)
E/GeckoAppShell( 3294): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoAppShell( 3294): 	at java.lang.reflect.Method.invoke(Method.java:511)
E/GeckoAppShell( 3294): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:793)
E/GeckoAppShell( 3294): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:560)
E/GeckoAppShell( 3294): 	at dalvik.system.NativeStart.main(Native Method)
Blocks: 895837
Whiteboard: abouthome-hackathon
Attached patch PatchSplinter Review
Comment on attachment 781883 [details] [diff] [review]
Patch

One liner.
Attachment #781883 - Flags: review?(margaret.leibovic)
Crash Signature: [@ java.lang.RuntimeException: You must supply layout attribute at org.mozilla.gecko.widget.IconTabWidget.<init>(IconTabWidget.java)]
Keywords: crash
Attachment #781883 - Flags: review?(margaret.leibovic) → review+
http://hg.mozilla.org/projects/fig/rev/8bd773e788eb
Assignee: nobody → sriram
Whiteboard: abouthome-hackathon → abouthome-hackathon, fixed-fig
I backed this out because bug 895837 was causing rc2 failures on fig:
https://hg.mozilla.org/projects/fig/rev/1ae4d0688fb1

We can re-land this whenever that issue is resolved.
Whiteboard: abouthome-hackathon, fixed-fig → abouthome-hackathon
Folded in with patch landed for bug 895837: https://hg.mozilla.org/projects/fig/rev/a0890fdc1346
Whiteboard: abouthome-hackathon → abouthome-hackathon, fixed-fig
Duping because fix was folded into bug 895837.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: abouthome-hackathon, fixed-fig → abouthome-hackathon
Duplicate of bug: 895837
You need to log in before you can comment on or make changes to this bug.