Context menu for .eml files is broken

RESOLVED FIXED in Thunderbird 26.0

Status

Thunderbird
Message Reader UI
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: squib, Assigned: squib)

Tracking

({regression})

24 Branch
Thunderbird 26.0
regression

Thunderbird Tracking Flags

(thunderbird24+ fixed, thunderbird25 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This is fallout from bug 179033. Opening an .eml file throws the following error, which (among other things?) breaks the context menu so everything is shown:

Error: TypeError: message.folder is null
Source File: chrome://messenger/content/folderDisplay.js
Line: 1956

We need to make sure the message is not external before using message.folder.

Updated

4 years ago
tracking-thunderbird24: --- → ?
Hardware: x86_64 → All
Version: unspecified → 24
(Assignee)

Comment 1

4 years ago
Created attachment 782033 [details] [diff] [review]
Fix this

Here's a quick fix for it.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #782033 - Flags: review?(mkmelin+mozilla)

Comment 2

4 years ago
Comment on attachment 782033 [details] [diff] [review]
Fix this

Review of attachment 782033 [details] [diff] [review]:
-----------------------------------------------------------------

Thx for the fix! r=mkmelin
Attachment #782033 - Flags: review?(mkmelin+mozilla) → review+

Updated

4 years ago
Keywords: regression
OS: Linux → All
So I think because bug 179033 got backed out, this doesn't need to be in TB 24?
tracking-thunderbird24: ? → -

Comment 4

4 years ago
(In reply to Mark Banner (:standard8) from comment #3)
> So I think because bug 179033 got backed out, this doesn't need to be in TB
> 24?

No, bug 179033 landed for tb24, it's just open because i wanted to figure out the test (which is awaiting review from you).

So this is needed for tb24.

Updated

4 years ago
tracking-thunderbird24: - → ?
tracking-thunderbird24: ? → +
I've pushed this so we can get it in for the upcoming beta:

https://hg.mozilla.org/comm-central/rev/05296139dcd0
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 26.0
Comment on attachment 782033 [details] [diff] [review]
Fix this

[Triage Comment]
a=me as this is a regression fix.
Attachment #782033 - Flags: approval-comm-beta+
Attachment #782033 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/3163066a4f54
https://hg.mozilla.org/releases/comm-beta/rev/31e202c7c583
status-thunderbird24: --- → fixed
status-thunderbird25: --- → fixed
You need to log in before you can comment on or make changes to this bug.