Installer over Remote X excrutiatingly slow

RESOLVED FIXED in Future

Status

RESOLVED FIXED
18 years ago
13 years ago

People

(Reporter: mozilla, Assigned: slogan)

Tracking

({perf})

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2+) Gecko/20010708
BuildID:    2001070806

When I run the installer over a remote X connection, everything is extremely
slow - it just took me over 45 minutes to install the latest nightly.  I know it
is not my connection to my server; all other apps, gtk, kde, and mozilla itself
once it is installed, run fine.  Also, the problem does not seem to be that the
installer is sending extraordinarily large amounts of X information, as I can
run other applications, even the GIMP, while installing.

Reproducible: Always
Steps to Reproduce:
1. Establish a remote X connection to some other computer.
2. Attempt to run the installer.
3. Go get a cup of coffee.

Actual Results:  Rendering of buttons, text, and everything else is very slow -
painting of the individual lines and rectangles is visible.  This creates a huge
problem during the actual install, as every time a file is extracted it repaints
the progress bar.

My connection is over AT&T cable and ping times to my X server are aprox 50ms. 
But again, this is not a problem for every other app I run.

Comment 1

18 years ago
why is this assigned to the editor group?
anthonyd

ps. bug acitivty doesnt reveal who assigned this to me, but someone must be 
confused.

reassigning to beth so she can send it over to what ever team handles the 
installer.
Assignee: anthonyd → beppe

Comment 2

18 years ago
installer folks
Assignee: beppe → ssu
Component: DOM Traversal-Range → Installer
QA Contact: lchiang → gemal
-> syd
Assignee: ssu → syd

Updated

18 years ago
QA Contact: gemal → gbush

Comment 4

18 years ago
Marking NEW.
Assignee: syd → ssu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
QA Contact: gbush → gemal
*sigh*, back to syd and Grace.
Assignee: ssu → syd
QA Contact: gemal → gbush

Comment 6

18 years ago
I get this behaviour running the installer over X locally. Could this be the
same bug?

My guess is that the installer only polls the X server as often as it recieves
data, so using the installer on a slow connection, it is unresponsive. Comments?
Since bug 112618 makes installer the _only_ way to install nightlys, this
becomes dogfood for me (and I'm sure for a number of other people).

There's no way a SEA should take 45 minutes to install (that's what it takes here).
(Assignee)

Updated

18 years ago
Target Milestone: --- → M1
(Assignee)

Updated

18 years ago
Target Milestone: M1 → Future

Comment 8

15 years ago
"silent mode" will avoid this problem.

./mozilla-installer -ms

you have to set the appropriate options beforehand in config.ini
This is fixed; the installer used to xsync, which made it ridiculously slow. 
The xsync call has been removed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.