Specific PDF renders with garbage characters

RESOLVED FIXED in Firefox 27

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kats, Unassigned)

Tracking

24 Branch
Firefox 27
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3674, URL)

Attachments

(1 attachment)

203.21 KB, application/pdf
Details
When I attempt to view the PDF in the URL field in my Aurora build of FF, it shows up with garbage characters. Opening the PDF in Mac OS X Viewer renders fine.

Comment 1

4 years ago
Created attachment 782266 [details]
cib_502_en.pdf

Same with F25 on Win 7.

Updated

4 years ago
Priority: -- → P3
Hardware: x86 → All
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]

Updated

4 years ago
Duplicate of this bug: 908474

Updated

4 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3674
Confirmed upto "PDF efded5c2001a48f5a5d1f2ffcb5a4 [1.5 http://big.faceless.org/products/pdf?version=2.11.12 / -] (PDF.js: 0.8.505)

i.e. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20131010004002 CSet: 3f16dc100b1f

Fixed with "PDF efded5c2001a48f5a5d1f2ffcb5a4 [1.5 http://big.faceless.org/products/pdf?version=2.11.12 / -] (PDF.js: 0.8.558)"

against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131010030202 CSet: aa986b6ce882
OS: Mac OS X → All

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 922693
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.