Enhancement Idea: Implement Google Site Search and similar into OpenSearch Box

RESOLVED DUPLICATE of bug 360907

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 360907
5 years ago
5 years ago

People

(Reporter: gaming4jc2, Unassigned)

Tracking

22 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20130627 Iceweasel/22.0 (Nightly/Aurora)
Build ID: 20130627101057

Steps to reproduce:

1) Go to a site containing lots of information but no search engine.
2) Manually copy the hostname and prepare it for a google site search...
3)Paste the following query into the current Google OpenSearch:
site:bugzilla.mozilla.org bugs

4) Press Enter.



Actual results:

I am then able to search for the term "bugs" only on the bugzilla.mozilla.org site.


Expected results:

A much nicer idea would be:
1) Click the dropdown menu in the OpenSearch bar.
2) Click a checkbox or other means of "Use this search engine on current website"
3) Type my search query.

In this way I wouldn't need the "site:hostname query" which is confusing for some.
The same query works with Google, Bing, Yahoo, DuckDuckGo, and StartPage. So it shouldn't be difficult to implement between engines and it resolves the need for making this into an extension when it can be included directly.
(Reporter)

Comment 1

5 years ago
Dropping to enhacnment and triaging.
Severity: normal → enhancement
Component: Untriaged → Search
Thanks for the report. Bug 360907 seems to cover the temporary site search use case whereas bug 482229 covers persisting the site-search engine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360907
You need to log in before you can comment on or make changes to this bug.