[Click To Play] Notification icon issue in the Location Bar

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Mehmet, Unassigned)

Tracking

25 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130725195523

Steps to reproduce:

1. Run latest Nightly
2. Set the Flash Plug-In to 'Allow Always'
3. Restart Nightly
4. Go to youtube.com




Actual results:

The Click To Play notification icon appears further on the location bar. (This is annoying, because I set it to 'Allow Always'. I do not need any further demand...


Expected results:

There should no be a Click To Play notification icon in the location bar, when I set it to allow always.


Another issue is, when I go to about:config and set 'plugins.click_to_play' to 'false', restart Nightly and go to youtube.com, then the Click To Play notification icon also still appear.
(Reporter)

Updated

5 years ago
Version: 23 Branch → 25 Branch

Updated

5 years ago
Blocks: 738698
Component: Untriaged → Plug-ins
Product: Firefox → Core
The behavior is not controlled by "plugins.click_to_play" anymore - only the addon manager still changes behavior based on that.

The click-to-play icon in the URL bar allows you to change the plugin permissions per site. The icon is always being shown as there is no better, discoverable, way yet to put this. There is work underway for a discoverable, more general, site permission dialog, but it will be a while until that is done.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.