history view doesn't refresh properly when selecting a filter

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: assiduous, Unassigned)

Tracking

22 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 782273 [details]
FieldsNotUpdated.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1. Start Firefox x86 in Windows 7.
2. Go to History view
3. Click on "Today" to view the sites visited today.
4. Click on "Yesterday" to view the sites visited yesterday.
5. Check the details of the (selected) site in bottom view (containing Name, Location, Tags field)


Actual results:

Only Name field appears. (See attachment)


Expected results:

All three fields - Name, Location, Tags should have been displayed.
If site is selected again in the main view, all these fields will get updated and displayed.

Updated

4 years ago
Component: Untriaged → Bookmarks & History

Comment 1

4 years ago
Because in your screenshot, the mouse is focused on "last 7 days', not on a website entry.

I tried with FF22 on Win 7, selecting a website in the history displays its details (name, location, tags).

Could you try in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) and with a new profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles maybe you can copy and paste the file places.sqlite between profiles to have an history in your new profile)
Flags: needinfo?(assiduous.learner)
(Reporter)

Comment 2

4 years ago
Sorry for the late reply. if the behavior is expected, I will change state to invalid.

I expected behavior to be same as when we first enter the History tab but as Loic mentioned the focus is not on a website entry and hence the observation is not valid. Hence, changing the state.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(assiduous.learner)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.