Closed Bug 898932 Opened 9 years ago Closed 6 years ago

Hardware acceleration w nVidia causes Windows 8 systems crash

Categories

(Core :: Graphics, defect)

22 Branch
x86
Windows 8
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bob.marietta, Unassigned)

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Have a nVidia GTX 560 ti video card. Somewhere along the lines of installing the Geforce experience software and Firefox update system has been crashing hard. Locks up Win 8 completely and have to hard reset with power off. Tried downgrading to v314.22 of nVidia software but same issue persisted. Googled it, others said to disable hardware acceleration in Firefox to fix the issue. Definitely seems to be coming from Firefox, issue only occurs when using Firefox. When I disabled hardware acceleration issue resolved. Would happily provide debug info but not sure where I could find it. Occasionally Win 8 detects an nVidia kernal driver error and recovers but more often it crashes.
(In reply to bob.marietta from comment #0)
> Definitely seems to be coming from Firefox, issue only occurs when using Firefox. 
> When I disabled hardware acceleration issue resolved.
It comes from your graphical setup because the Firefox code has no way to crash the OS.

Type about:crashes and provide some related crash IDs if there are some.
Severity: normal → critical
Component: Untriaged → Graphics
Flags: needinfo?(bob.marietta)
Keywords: crash, stackwanted
Product: Firefox → Core
Hardware: x86_64 → x86
Thanks for your response. I suspect the crash is caused by some type of interaction between FireFox and the nVidia drivers for two reasons. (1) crash only occurs when I'm using FireFox (2) occasionally a Windows(?) dialog pops up and says nVidia kernel error recovered and (3) disabling hardware acceleration inside of FireFox fixed the problem.

When the problem occurs, the screen drastically slows down for about 15 seconds (mouse cursor begins to lag). Then the screen completely freezes resulting in my having to power down.

about:crashes is empty.

Is there any other information I could provide about this? Would there be a Windows log or nVidia driver log that would be helpful?
Flags: needinfo?(bob.marietta)
Do you have reliable steps to reproduce?

(In reply to bob.marietta from comment #0)
> Somewhere along the lines of installing the Geforce experience software and Firefox
> update system has been crashing hard. Locks up Win 8 completely and have to hard
> reset with power off. Tried downgrading to v314.22 of nVidia software but same issue
> persisted.
Is Geforce experience software separate from NVIDIA drivers? If it does, do uninstalling it fix the issue?
Also, does downgrading to Firefox 21 fix the issue (see https://support.mozilla.org/kb/install-older-version-of-firefox)?
Flags: needinfo?(bob.marietta)
Keywords: stackwanted
The GeForce experience software came with the 320.18 driver. It appears to be a driver wrapper that selects optimal configuration for games. I tried 320.49 and the problem still persisted. I uninstalled all the nVidia software and reverted back to 314.12. To my surprise FireFox kept crashing the whole system. Then I Googled the issue and found the recommendation to disable hardware acceleration inside of FireFox. Once I did that all the crashing stopped. Trying FireFox 21 as you requested.
Flags: needinfo?(bob.marietta)
(In reply to bob.marietta from comment #4)
> Trying FireFox 21 as you requested.
Let's wait for that.
Flags: needinfo?(bob.marietta)
I'm not sure if this is the same bug or not, but I do have reproducible steps that cause Firefox to crash:

------------------------------
BUG REPORT:
Certain animations in Firefox (specifically, sending emails in Outlook.com) make Firefox close unexpectedly when Hardware Acceleration is enabled.

Steps to reproduce:
1) Install Firefox
2) Ensure Hardware Acceleration is enabled:
Options -> Advanced -> General -> Use hardware acceleration when available
(Make sure the option is checked; restart Firefox if you just checked that option)
3) Go to Outlook.com and log in
4) Send an email (ie: a test email to yourself)
5) Firefox crashes

If it doesn't crash on the first attempt, just keep sending emails until it crashes.

Broken for me, on:
Windows 8.1 Preview x64 (latest; fully patched)
Firefox 23.0.1 (latest; fully patched)
nVidia Drivers 326.80 Beta (latest)
GTX 660 Ti (with 2 other GPUs not connected to any monitor; GTX 460, GTS 240)

Workaround:
1) Disable Hardware Acceleration:
Options -> Advanced -> General -> Use hardware acceleration when available
(Make sure the option is unchecked)
2) Restart Firefox
------------------------------

Is this problem a Firefox problem, or is it an nVidia driver problem?
The issues in comment #6 sound different, because they are Firefox crashes.  (And they might be bug 805406.)

The original issues with this bug sound like hardware or driver instability issues.  They may be being tickled by something that Firefox is doing, but nothing that Firefox does should cause a hard system or driver crash.  Disabling hardware acceleration in Firefox "fixes" it by just not using the GPU, thus not touching the paths inside the driver/system that are causing the instability.

Do you have problems in any other graphically intensive apps or games?  Running something like FurMark -- http://www.ozone3d.net/benchmarks/fur/ -- and seeing if it's stable would be an interesting test.
I'm having this issue as well, it occurs under Windows 7 or 8 with a GeForce 560Ti. Sometimes Windows will report that display driver has crashed, other times it doesn't recover and I have to reset it. Same symptoms as the others, the mouse will slow down then stop responding entirely. Disabling hardware acceleration in Firefox fixes it. 

I have tested my entire system front to back, memtest and GPU tests. I can play graphically intensive games for hours with no issues at all, but Firefox will crash it every time.
I can confirm this issue on NVIDIA GTX 460 and Windows 8.1 Pro with latest display drivers. Sometimes (usually when I cover a link with a mouse) display driver stops working and tries to restart. Usually it restarts successfully, but sometimes it locks up my system and the GPU fan starts working with max speed. Then only solution is hard reset.
The issue only occurs in Firefox, I can't reproduce it in any game or other browser...

Disablind HW acceleration in FF seems to be a solution but I think it's clearly a bug with Firefox HW acceleration.
I'm having this issue too. It happens rather predictably for me when switching from EA's N7HQ site (the Galaxy at War feature specifically) to another tab, and is preceded by the tab row losing 3d edges around tabs (but that happens when using Galaxy at War whether or not a crash is imminent). A few seconds later, the mouse pointer starts lagging, then freezes for a few seconds. Then the screen goes black, comes back (without glass effects for a few seconds), Firefox has died and the crash reporting tool is visible, and Nvidia's driver reports a driver reset. Then I can restart Firefox and continue working normally until it happens again under the same circumstances.

As with the other reports here, the driver reset only happens when using Firefox with hardware accelleration enabled. Memtest and every other stability test I've thrown at my system checks out. I can't reproduce the driver crash in games or other GPU-intensive programs.

My system:
Windows 8.1 Pro x64
Nvidia GTX 660, driver 334.89 WHQL
I'm having this issue too. It happens rather predictably for me when switching from EA's N7HQ site (the Galaxy at War feature specifically) to another tab, and is preceded by the tab row losing 3d edges around tabs (but that happens when using Galaxy at War whether or not a crash is imminent). A few seconds later, the mouse pointer starts lagging, then freezes for a few seconds. Then the screen goes black, comes back (without glass effects for a few seconds), Firefox has died and the crash reporting tool is visible, and Nvidia's driver reports a driver reset. Then I can restart Firefox and continue working normally until it happens again under the same circumstances.

As with the other reports here, the driver reset only happens when using Firefox with hardware accelleration enabled. Memtest and every other stability test I've thrown at my system checks out. I can't reproduce the driver crash in games or other GPU-intensive programs.

My system:
Windows 8.1 Pro x64
Nvidia GTX 660, driver 334.89 WHQL
Firefox 27.0.1
Sorry about the double post guys, Bugzilla threw a SQL error on submitting but must have still silently accepted the comment.
I have the exact same issue. Firefox with hardware accelaration locks up and eventually crashes my system. Issue exists since a driver update of my gfx card somewhere in june/july 2013.


System: 

Windows 8.1 pro x64
NVIDEA GTX560ti, driver 335.23
Firefox 27.0.1
Wow, so happy i found this.

Gigabyte 780ti (340.52 and 377.88 drivers)
Win7 64bit
4700k 3.5ghz


Been having random system freezes with Firefox (Hardware acceleration enabled), where the mouse lagged for a few seconds, then froze completely. Had to reboot system to regain control.

I've been unsure if this was a bug with my drivers or my actual GPU (Gigabyte 780ti is known to be a potentially unstable card), so this may help me out. I've disabled Hardware Acceleration to see if it works, i will post again if i DO crash with the option turned off.
wolfie87  absolutly same thing
780 gtx
340.52 driver
on 377.88  and   firefox 31 and lower version 
worked 3 monts without hardlock and freeze

Updated to 32 firefox.
hardlocks.Freeze. GPU Cooler worked in freezed state at max.
Only  when scrolling. In random moment
But mostly in sites with big pictures
Getting same thing as described in above comments. Mouse/Screen starts to lag/stutter for a few seconds, then a complete freeze occurs. 

Firefox 32.0.3
Intel i7 2600k
Nvidia 780Ti - 344.11 drivers. 

Haven't tried the newest stable Firefox version, but I will test it out and see if anything like this occurs again.
I also suspect that hardware acceleration may be crashing my system. I've been using FF with HWAcc. disabled for the past 21 days, no crashes so far.

I'm on Nvidia 9600GT. With HWAcc. enabled, the graphics card will haphazardly crash either during 3D games or at the moment of starting a Youtube video (this is the strongest indicator that it's a HWAcc. issue). I can't think of a way to reproduce this, seems very random. I've gone back and tried 5+ year old drivers, the only one that wasn't crashing was version 175.80 from 2008, but I doubt it even takes HWAcc. into account.

I'll give it another 2 weeks, then turn HWAcc. back on. No major changes were made to my system since it was disabled so it should be pretty clear whether it's causing the crashes or not.

Using:
Firefox 41.0.1 (last crash on FF39 or FF40, don't remember)
Windows 7, 64-bit
Nvidia GeForce 9600GT
Driver 306.23 (3d vision not installed, PhysX not installed)
Any update Zavil?
Flags: needinfo?(demoneee)
While FF stopped crashing my graphics card after turning hwacc. off, 3D video games did not. It turns out, mine was a hardware issue. As a last ditch effort (you can thank Wasteland 2 for that), I made a single change in my motherboard's BIOS: I lowered the PCI-E speed from 100mHz to 95mHz. I wish I had thought of this 3 years ago. The games stopped crashing, as did FF with hwacc. on. No crashed in the past month.
So there you go.

ps:
I haven't got a good excuse for not posting this sooner, so just deal with it :P. But seriously, FF is ok.
Flags: needinfo?(demoneee)
Thanks for writing back Zavil. I'll close this bug is WORKSFORME based on your comment.

Bob, please reopen this bug report if you can still reproduce it in the latest Firefox version. Perhaps try to see if Zavil's workaround solves your problem too.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(bob.marietta)
You need to log in before you can comment on or make changes to this bug.