Closed Bug 898940 Opened 6 years ago Closed 6 years ago

Audio controls missing when player started with play()

Categories

(Toolkit :: Video/Audio Controls, defect)

24 Branch
x86_64
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox23 --- unaffected
firefox24 + fixed
firefox25 + fixed
firefox26 + fixed

People

(Reporter: ron, Assigned: roc)

References

Details

(Keywords: regression, testcase)

Attachments

(3 files)

In the following minimal snippet, aurora makes the widget vanish
while it is playing, and it only appears after playback finishes.
If not intentional, then it's a regression from 22 and beta, if it
is, then it seems like an undesirable feature, if there is no way
to prevent it from occurring.


    <html><body>

    There should be an audio widget below here:<br>
    <audio id='player' src='foo.ogg' controls></audio>
    <br>There should be an audio widget above here.

    <script>
    document.getElementById('player').play();
    </script>

    </body></html>
WFM on OS X Nightly with http://dolske.net/mozilla/tests/video/sizes_audio.html, what do you see?
The sizes_audio.html page works ok for me (they're crowded vertically, but otherwise work).  The trick to the test code I posted though is the js play() operation.  That's what makes the widget vanish in aurora.  When it starts playing the widget disappears, when playing finishes it fades back in.

Clicking the play button on the widget does not show this behaviour, that works fine too.
Attached file 898940.html (testcase)
Regression range:
good=2013-05-28
bad=2013-05-29
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c190422547ed&tochange=e58336e81395

Maybe Bug 876426.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Regression in aurora audio widget? → Audio controls missing when player started with play()
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/0f9247a41a5e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130528 Firefox/24.0 ID:20130528065031
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6a70ea277263
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130528 Firefox/24.0 ID:20130528070232
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0f9247a41a5e&tochange=6a70ea277263

Regressed by: 
  6a70ea277263	Robert O'Callahan — Bug 876380. Update 'show clickToPlay button' state after each load. r=dolske
Blocks: 876380
OS: Linux → All
Needinfo'ing :roc to get his insight on the issue as this may be FX24 regression if its a fallout form 876380 and the severity for it to be tracking worthy to understand its impact outside of the testcase.
Flags: needinfo?(roc)
It looks like the problem only occurs when the controls binding is attached after the element has started playing.
Flags: needinfo?(roc)
Assignee: nobody → roc
Attached patch TestSplinter Review
I haven't been able to run this test yet since running mochitests locally is currently broken on mozilla-central.
Attachment #784199 - Flags: review?(jaws)
Attachment #784156 - Flags: review?(jaws) → review+
Attachment #784199 - Flags: review?(jaws) → review+
https://bugzilla.mozilla.org/show_bug.cgi?id=898940

I'll land the test separately since I haven't run it yet.
https://hg.mozilla.org/mozilla-central/rev/91f4bd08f12b
https://hg.mozilla.org/mozilla-central/rev/b8f4739d9ff6
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Comment on attachment 784156 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 876380
User impact if declined: audio elements with built-in controls may disappear (regression)
Testing completed (on m-c, etc.): just landed
Risk to taking this patch (and alternatives if risky): simple low-risk patch
String or IDL/UUID changes made by this patch: none
Attachment #784156 - Flags: approval-mozilla-beta?
Attachment #784156 - Flags: approval-mozilla-aurora?
Attachment #784156 - Flags: approval-mozilla-beta?
Attachment #784156 - Flags: approval-mozilla-beta+
Attachment #784156 - Flags: approval-mozilla-aurora?
Attachment #784156 - Flags: approval-mozilla-aurora+
The test failed because the audio.ogg test file my test used isn't present on beta. I made the test use audio.wav which is present, and it passes.
https://hg.mozilla.org/releases/mozilla-beta/rev/674ac4de277c
https://hg.mozilla.org/releases/mozilla-beta/rev/3c7b2971e44f
Flags: needinfo?(roc)
You need to log in before you can comment on or make changes to this bug.