If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Helix][Buri][Browser] It fails to save image, video and audio using a gesture in web page.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Browser
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: hlu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sprintready]; dupme?, permafail)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 782485 [details]
logcat

* Build Number (Both Gecko and Gaia)
Gaia:     f2bc4a004f592cd6dce4edda2b0533f4fd4f91f2
  B-D     2013-07-25 18:32:32
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/2bb08f2878da
BuildID   20130725070202
Version   18.0

* Reproduce Steps
1. Open the browser from the home screen
2. Go to a web page with videos that can be downloaded for example: http://people.mozilla.com/~atrain/mobile/tests/media.html
3. long tap on the video
4. select save video

* Actual results
Could not find the video via Gallery, Video apps and also not find it in SDCard.

* Expected results
In step 4, the video saves to the sdcard as long as there is space on the SDcard
(Reporter)

Comment 1

4 years ago
It's also fails to save audio using a gesture in web page.
Summary: [Helix][Browser] It fails to save video using a gesture → [Helix][Browser] It fails to save video/audio using a gesture in web page.
(Reporter)

Updated

4 years ago
Summary: [Helix][Browser] It fails to save video/audio using a gesture in web page. → [Helix][Browser] It fails to save image, video and audio using a gesture in web page.
Whiteboard: [sprintready]

Comment 2

4 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/55164550

Updated

4 years ago
Whiteboard: [sprintready] → [sprintready]; burirun1

Updated

4 years ago
Duplicate of this bug: 915051

Updated

4 years ago
Duplicate of this bug: 915042

Comment 5

4 years ago
Reproduces on Buri 1.2.0. Also, the user is able to save one video/image/audio file correctly and then this issue will occur and nothing can be saved past that.

Environmental Variables
Build ID: 20130911040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/f9e8e8ce552c
Gaia: ebbb325958c66c3e68e1f190472d5f6e9076d83a
Platform Version: 26.0a1
Summary: [Helix][Browser] It fails to save image, video and audio using a gesture in web page. → [Helix][Buri][Browser] It fails to save image, video and audio using a gesture in web page.
Whiteboard: [sprintready]; burirun1 → [sprintready]; burirun1, dupme?
Naoki - Is this bug even valid right now? We've fixed bugs around this and the behavior seen in comment 5 is a different bug. Can you figure out what to do with this bug to see if it still holds validity?
Flags: needinfo?(nhirata.bugzilla)
1.1HD and 1.2 are on different channels, so I'm not sure jsmith.  I'd have to retest.  The pushes would have to be done to 1.1 HD.  I'll try to look at it in today's 1.1 HD build.
Flags: needinfo?(nhirata.bugzilla)
This works for me 1.1 HD:
Gaia   0f8d0681d9133f488e10f8f3dadd3477cd594767
SourceStamp 0f1ee7f92a79
BuildID 20131001042214
Version 18.0
Helix
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Whiteboard: [sprintready]; burirun1, dupme? → [sprintready]; burirun1, dupme?, burirun2
Whiteboard: [sprintready]; burirun1, dupme?, burirun2 → [sprintready]; burirun1, dupme?, burirun2, burirun3

Updated

4 years ago
Whiteboard: [sprintready]; burirun1, dupme?, burirun2, burirun3 → [sprintready]; dupme?, permafail
You need to log in before you can comment on or make changes to this bug.