Copying numbered list item into plaintext copies as an unordered list item

VERIFIED WORKSFORME

Status

()

Core
Editor
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Blake Ross, Assigned: anthonyd)

Tracking

Trunk
mozilla0.9.4
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 2001070708

Steps to Reproduce:

1. Open the Help viewer (Help | Help Contents)
2. Go to Browsing the Web > Improving Speed and Efficiency > Managing Different
File Types
3. Scroll down to the list of steps that are preceded by "To remove an item from
the list:"
4. Highlight the second step. Start from the end of the sentence and drag to the
left, over the "2." (it won't get visibly selected).
5. Press ctrl+c.
6. Paste anywhere.

Actual result: "   1. Click OK or Cancel in response to the warning dialog." is
pasted.

Expected result: should be "2."

Comment 1

17 years ago
the actual list marker number would not be preserved in that manner, when you 
paste, you are pasting the ol and just one li -- which would result in a 
numbering scheme of 1., you would need to go to the list properties sheet to 
alter the number.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
What if you are pasting into plain text? Then you would expect to see "2."

Comment 4

17 years ago
yes, plaintext would be different. I just sat with Akkana and the plaintext
paste of a numbered list item is not getting interpretted correctly. It is
pasted into plaintext as an unordered list item.

Assigning to Anthony, cc Akkana and mozilla@bucksch.org

Also updating summary
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
Summary: Copying second item in list copies "1." → Copying numbered list item into plaintext copies as an unordered list item

Comment 5

17 years ago
off to anthonyd
Assignee: beppe → anthonyd
Status: REOPENED → NEW

Comment 6

17 years ago
We think that the context info includes the fact that it's in an ol rather than
a ul, because pasting into an html editor preserves it as an ol.  But when it's
serialized to plaintext, the context information is being lost (conjecture).

Comment 7

17 years ago
*** Bug 91299 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

17 years ago
moving to 0.9.4
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 9

16 years ago
i cannot repro this on windows with a current build.

i copied a number list and pasted it into notepad successfully, got the numbers 
and everything, even nesting.

marking bug as worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED

Comment 11

16 years ago
I'm only using build ID: 2001082303 but when I copy a list item and paste it
into notepad it is always numbered "1." instead of the actual number displayed.
You need to log in before you can comment on or make changes to this bug.