Database Upgrade message is present in Gallery even if the SD card is empty

RESOLVED FIXED

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Bebe, Assigned: johnhu)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g18 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1. Flash a Unagi with the latest master build:
Gecko  http://hg.mozilla.org/mozilla-central/rev/73b69c146ca6
Gaia  ad923e915a38394497da682c3024ccc37390b52a
BuildID 20130728030202
Version 25.0a1

2. Make sure the SD card has no photos 
3. Open Gallery app

Expected:
3. the normal "No photos or videos" message should be visibile

Actual:
3. "Database Upgrade" message is present

Screenshot:
http://imgur.com/ggQCapA

I think this is related with Bug 891797
Assignee: nobody → johu
This is a regression bug made by Bug 891797 which is made by me. I will fix that, ASAP. Sorry about that.
Component: Gaia::Gallery → General
Summary: Database Upgrade message is present in Gallery even if the SD card is empty → Database Upgrade message is present in Gallery, Music, and Video even if the SD card is empty
Sorry, this bug only happens to Gallery. There is a missing "break" at the case of emptygallery[1]. I will start to prepare the patch for this bug.

[1] https://github.com/mozilla-b2g/gaia/blob/56ec34e93f1985578a5e2f2d70f9bd0fd15dc164/apps/gallery/js/gallery.js#L1150
Component: General → Gaia::Gallery
Summary: Database Upgrade message is present in Gallery, Music, and Video even if the SD card is empty → Database Upgrade message is present in Gallery even if the SD card is empty
Created attachment 782921 [details]
add the "break" back

I am so sorry about this bug. It's a small missing break bug. This patch put the "break" back.
Attachment #782921 - Flags: review?(dflanagan)
Since the source of this bug is Leo+, we should nominate it as leo?
blocking-b2g: --- → leo?
Marking this a regression and tracking
blocking-b2g: leo? → leo+
Keywords: regression
Comment on attachment 782921 [details]
add the "break" back

If I had known this was a one-line patch I would have reviewed it sooner! :-)

I'll go ahead and land and uplift it since it is the weekend already in taiwan.
Attachment #782921 - Flags: review?(dflanagan) → review+
Landed on master: https://github.com/mozilla-b2g/gaia/commit/0918120dcd1896c2331682c4291596db6b5badf0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → affected
Resolution: --- → FIXED
I tried to uplift this but found that the regressing bug 891797 has not been uplfited yet.  This should be uplifted right after that one.
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 0918120dcd1896c2331682c4291596db6b5badf0
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(johu)
This bug mainly depends on the code of bug 830239. Since the nominating of bug 830239 is rejected. And the source of this bug is bug 891797. Bug 891797 had also changed the dependency part of bug 830239 to another version for v1-train. So, this bug is also no need to uplift to v1-train. De-nominate it as leo?.
blocking-b2g: leo+ → leo?
Flags: needinfo?(johu)

Updated

5 years ago
blocking-b2g: leo? → -
You need to log in before you can comment on or make changes to this bug.