Closed Bug 899349 Opened 7 years ago Closed 7 years ago

Intermittent crashtests/366537-1.xhtml,367587-1.html | load failed: timed out waiting for reftest-wait to be removed followed by many more

Categories

(Core :: Layout, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox24 --- unaffected
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: RyanVM, Assigned: mats)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Mats, any chance you could take a look at this? Appears to be Win7/Win8 only.

https://tbpl.mozilla.org/php/getParsedLog.php?id=25800157&tree=Mozilla-Inbound

WINNT 6.2 mozilla-inbound opt test crashtest on 2013-07-26 14:42:03 PDT for push d0a9de949678
slave: t-w864-ix-004

14:47:28     INFO -  REFTEST TEST-START | file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml
14:47:28     INFO -  REFTEST TEST-LOAD | file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml | 1153 / 2501 (46%)
14:52:28     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml | load failed: timed out waiting for reftest-wait to be removed
14:52:28     INFO -  REFTEST INFO | Saved log: START file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
14:52:28     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml
14:52:28     INFO -  REFTEST INFO | Saved log: Updating entire canvas for invalidation
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
14:52:28     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
14:52:28     INFO -  REFTEST INFO | Loading a blank page
14:52:28     INFO -  REFTEST TEST-END | file:///C:/slave/test/build/tests/reftest/tests/layout/forms/crashtests/366537-1.xhtml

etc...
The test looks fine to me, I can't see any reason why it would fail to remove
the class attribute on the last line in boom().
Occurs on more than just Windows.
Summary: Intermittent Win7/Win8 crashtests/366537-1.xhtml | load failed: timed out waiting for reftest-wait to be removed followed by many more → Intermittent crashtests/366537-1.xhtml | load failed: timed out waiting for reftest-wait to be removed followed by many more
Marked random-if on all platforms for too many intermittent failures:
https://hg.mozilla.org/integration/mozilla-inbound/rev/524707c0eed5
Whiteboard: [marked random-if][leave open]
17:05:01 - RyanVM: edmorley: is random-if going to work for Bug 899349?
17:05:13 - RyanVM: edmorley: AFAICT, the issue is with loading the test to begin with
17:05:20 - RyanVM: I think it needs to be skip-if
17:05:31 - RyanVM: or just skip(1)

remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/834374d5596f
Whiteboard: [marked random-if][leave open] → [marked skip-if][leave open]
So we're still hitting this, but now in 367587-1.html. Mats, maybe a similar issue to bug 874073?
Summary: Intermittent crashtests/366537-1.xhtml | load failed: timed out waiting for reftest-wait to be removed followed by many more → Intermittent crashtests/366537-1.xhtml,367587-1.html | load failed: timed out waiting for reftest-wait to be removed followed by many more
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #50)
> So we're still hitting this, but now in 367587-1.html. Mats, maybe a similar
> issue to bug 874073?

If it's a modal dialog that's causing the problem then I think you would have this
assertion on shutdown in debug builds (at least on Linux which is what I tested
in bug 874073):
###!!! ASSERTION: Uh, LeaveModalState() called w/o a reachable top window?

Anyway, I submitted a Try job with some setTimeout logging:
https://tbpl.mozilla.org/?tree=Try&rev=b119f6fcf81b
There were zero failures on Linux64 so let's try win32 and OSX:
https://tbpl.mozilla.org/?tree=Try&rev=7ecb2d83346a
https://tbpl.mozilla.org/?tree=Try&rev=b2af75558aa4
Zero failures ... so I think the problem was fixed by bug 874073.
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [marked skip-if][leave open]
https://hg.mozilla.org/mozilla-central/rev/8b99e97bb3de
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.