If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Home page (Suggestion Box) links to an archived article

VERIFIED FIXED in 2013Q4

Status

support.mozilla.org
General
P4
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Scoobidiver (away), Assigned: rehan)

Tracking

unspecified
2013Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=wiki p=1 s=2013.21 [needsverify])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Click the Give us your feedback link on the Home page. You are redirected to an archived article.

Either unarchive this article (and close this bug as invalid) or remove the Suggestion Box from the home page.
(Reporter)

Comment 1

4 years ago
... and from the mobile menu.
Thanks, looks like this was missed in the navigation bar removal.
Priority: -- → P4
Whiteboard: u=user c=wiki p= s=2013.16
Target Milestone: --- → 2013Q3
We need to remove the link from mobile. Almost a 0 => 1pt
Whiteboard: u=user c=wiki p= s=2013.16 → u=user c=wiki p=1 s=2013.16
(Reporter)

Comment 4

4 years ago
Removing the box will unbalance the layout.
Maybe the remaining Help Other Users box in the home page and the Get Involved - Help Other Users button in product pages can be merged and put in an anchored place.
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #3)
> We need to remove the link from mobile. Almost a 0 => 1pt

My bad. There is "Suggestion Box" on the normal/desktop home page still. Need to remove that too and adjust CSS if necessary.

Comment 6

4 years ago
Created attachment 783524 [details]
Mozilla news - 01

Comment 7

4 years ago
Created attachment 783534 [details]
Mozilla news - 02

Comment 8

4 years ago
There are two ways that we can remove the right-hand box, incorporate the “get involved” button and make the list flows well at the same time.

The first way, visualized in attachment 783524 [details], is to expand the list to fill three columns rather than two.

The second way, attachment 783534 [details], is to lengthen the width of each item on the list to fill the entire 12 grid (940px).

In both treatments, we can use the “Get Involved” button already present on the product landing pages as an entry point to that page, unifying the appearance as a nice side effect.
(Reporter)

Comment 9

4 years ago
Bram, the Help Other Users button like already in the product page will be in an hidden area so nobody will click it.

Comment 10

4 years ago
(In reply to Scoobidiver from comment #9)
> Bram, the Help Other Users button like already in the product page will be
> in an hidden area so nobody will click it.

Could you clarify what you mean by “hidden”? If “hidden” means “user has to scroll down, so he will not see the entry point”, then what we may be able to do is move the “Get Involved” button on top of the Mozilla News.
(Reporter)

Comment 11

4 years ago
(In reply to Bram Pitoyo [:bram] from comment #10)
> Could you clarify what you mean by “hidden”? If “hidden” means “user has to
> scroll down, so he will not see the entry point”, then what we may be able
> to do is move the “Get Involved” button on top of the Mozilla News.
Yes, hidden in that context meant to scroll down the page to access it.

The Get Involved button is ugly (color and location) so importing it in the home page is not the right solution and will also make the layout unbalanced.

Maybe slightly shift down the current box so that the height of Mozilla News and Help other users box are close.

Comment 12

4 years ago
Right. So the problem seems to you to have two dimensions:
* The position is not efficacious
* The design is not attractive

We could fix the positioning problem by either:
* Moving the link up the page, above the “Mozilla News” section
* Keeping the link on the sidebar, but making it larger

Fixing the design problem is trickier, but it’s totally possible to do. We have to experiment with different ways to visualize the same entry point. For example: buttons, links, banners, etc. Then we measure which one gets the most users who actually become active contributors.

When doing this, keep in mind that not all clicks are good, because we want the right kind of clicks (users who truly want to contribute) versus the wrong kind (users who thought that “Get Involved” is the right place to solve their issues).
(Reporter)

Comment 13

4 years ago
I don't think this deserves a long survey so I am OK with the solution of comment 11.
Moving to next sprint.
Whiteboard: u=user c=wiki p=1 s=2013.16 → u=user c=wiki p=1 s=2013.17

Updated

4 years ago
Whiteboard: u=user c=wiki p=1 s=2013.17 → u=user c=wiki p=1 s=2013.17 [verifyme]
Whiteboard: u=user c=wiki p=1 s=2013.17 [verifyme] → u=user c=wiki p=1 s=2013.17 [needsverify]
NOTE regarding needsverify: this can be verified by just attaching or linking to a screenshot.
Swapping this one for bug 907215 in this sprint, and bumping this one to the next sprint.
Whiteboard: u=user c=wiki p=1 s=2013.17 [needsverify] → u=user c=wiki p=1 s=2013.18 [needsverify]
We are focusing on Open Badges and Persona in 2013.18
Whiteboard: u=user c=wiki p=1 s=2013.18 [needsverify] → u=user c=wiki p=1 s=2013.19 [needsverify]
Pushing to next sprint, since we are focusing on Q3 goals in this short sprint.
Whiteboard: u=user c=wiki p=1 s=2013.19 [needsverify] → u=user c=wiki p=1 s=2013.20 [needsverify]
Summary: Home page links to an archived article → Home page (Suggestion Box) links to an archived article
Duplicate of this bug: 917890
Q3 is over... => Q4
Target Milestone: 2013Q3 → 2013Q4
pushing to next sprint.
Whiteboard: u=user c=wiki p=1 s=2013.20 [needsverify] → u=user c=wiki p=1 s=2013.21 [needsverify]
(Assignee)

Updated

4 years ago
Assignee: nobody → rdalal
(Assignee)

Comment 22

4 years ago
Pushed to stage for verification.
Flags: needinfo?(a.topal)
Hey Rehan, could you please use the first mockup? https://bugzilla.mozilla.org/show_bug.cgi?id=899482#attach_783524

With the second one the links take a lot of space and they push the call to action for contributor way down the page.
Flags: needinfo?(a.topal) → needinfo?(mverdi)
(Assignee)

Comment 24

4 years ago
The reason I used the second mockup is because aesthetically it looks WAY better. The first mockup looks great as attached, but once you put real-world titles in there it gets messy fast. With two columns it was okay. With 3 it just looks like a mess. That being said I can make a change.

Comment 25

4 years ago
The second mockup version that is on allizom right now is fine but I do agree that it pushes the contributor button pretty far down. I think there are two solutions here: 1. reduce the number of news items or 2. remove the news items. From a quick check of GA it doesn't look like anyone uses these news items (or maybe we aren't/can't track that).
Flags: needinfo?(mverdi)
(Assignee)

Comment 26

4 years ago
There is a third option that I can think of which is instead of the little blue "Get Involved" button we could have a small but prominent "Get involved" section above Mozilla News. I'll mock something up shortly.
Michael, we need to track links manually (via events) in case they link to external pages. Unfortunately we haven't done that for news yet. 

On the other hand, the question is: Do we even want to send people to those news when they come to the support site? Honestly, I haven't spent too much time thinking about this page since it's used by only 1-3% of our visitors.

This bug was filed to remove the "dead" link from the start page, but we can certainly do some experimenting here.

Looking forward to your mock-up, Rehan.
(Assignee)

Comment 28

4 years ago
Created attachment 823432 [details]
gi-box.jpg

Here is a mockup of what I was thinking. It would leave the news as individual lines and have a little box highlighting the "Get Involved" section above the "News"
Flags: needinfo?(a.topal)

Comment 29

4 years ago
If people aren’t clicking on the News section, we can eliminate it. The original thinking behind putting it there was assuming that people who visits Mozilla Support come there for many reason, and that reason could be “I would like to know where I can hear how and what Mozilla is doing these days”, and it is associated (though only mildly) with the act of getting support.
Rehan, I love that mock-up!

Bram, yeah, I remember that we talked about that. I have a hard time though figuring out whether the benefit of having news for those who think “I would like to know where I can hear how and what Mozilla is doing these days” outweighs the downside of cluttering up the start page and unintentionally misleading people who want actual support. 

One indicator that that is going would be if people who click on news are unhappy afterwards (because they are actually looking for support). Unfortunately I don't know how to test for that. If you have any ideas, let me know. One crude way to figure out if people are really interested in what's going on with Mozilla would be to put a survey there and present it to anyone who is clicking on those links, but that's a bit invasive.
Flags: needinfo?(a.topal)
Rosana, Madalina, what do you guys think?
Flags: needinfo?(rardila)
Flags: needinfo?(mana)

Comment 32

4 years ago
(In reply to Rehan Dalal [:rehan, :rdalal] from comment #28)
> Created attachment 823432 [details]
> gi-box.jpg
> 
> Here is a mockup of what I was thinking. It would leave the news as
> individual lines and have a little box highlighting the "Get Involved"
> section above the "News"

That sure looks nice but it's WAY too much. That instantly becomes the biggest CTA on the page. We've been consistent about minimizing this particular CTA because this is NOT what 99.9something percent of users came here to do.

As far as the news links - can't we just delete them and see if our exit survey tanks? I know it's not a strict A/B test but if they were truly helpful and wanted I think we'd notice.
(Assignee)

Comment 33

4 years ago
(In reply to Verdi [:verdi] from comment #32)
> (In reply to Rehan Dalal [:rehan, :rdalal] from comment #28)
> > Created attachment 823432 [details]
> > gi-box.jpg
> > 
> > Here is a mockup of what I was thinking. It would leave the news as
> > individual lines and have a little box highlighting the "Get Involved"
> > section above the "News"
> 
> That sure looks nice but it's WAY too much. That instantly becomes the
> biggest CTA on the page. We've been consistent about minimizing this
> particular CTA because this is NOT what 99.9something percent of users came
> here to do.
> 
> As far as the news links - can't we just delete them and see if our exit
> survey tanks? I know it's not a strict A/B test but if they were truly
> helpful and wanted I think we'd notice.

I'm +1 on just deleting the news and seeing what happens.

Regarding the get involved CTA, we just landed this version but can roll it back. I can switch it out for just the blue button the way we had it, except appearing right below the product picker. The only thing I don't like about that is how much it throws the balance of the page off aesthetically. Another option might be to just throw it into the top nav (possibly only on the home page)?

Thoughts?

Comment 34

4 years ago
Created attachment 824194 [details]
Get involved in top nav

(In reply to Rehan Dalal [:rehan, :rdalal] from comment #33)
> Another option might be to just throw it into the top nav (possibly only on
> the home page)?
> 
> Thoughts?

You mean up there with log in and stuff - like this attachment? I LOVE that idea. That could go on all pages.
(In reply to Verdi [:verdi] from comment #34)
> Created attachment 824194 [details]
> You mean up there with log in and stuff - like this attachment? I LOVE that
> idea. That could go on all pages.

That's cool but there isn't enough space when logged in, especially in other languages:

http://cl.ly/image/14353z433p3U
(In reply to Kadir Topal [:atopal] from comment #27)
> this page since it's used by only 1-3% of our visitors.

Given this, we might want to stop beating the dead horse and move on at some point. Let's delete the news and maybe make the new section a little smaller. Like a typical banner ad size would be great IMO.
New version is on prod. I love how the fox is looking up over the fold and calling you to save the world. Not sure if this is good or bad, but maybe it helps gets us to 1 million Mozillians? :-P
clearing the NEEDS INFOs
Flags: needinfo?(rardila)
Flags: needinfo?(mana)

Comment 39

4 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #37)
> New version is on prod. I love how the fox is looking up over the fold and
> calling you to save the world. Not sure if this is good or bad, but maybe it
> helps gets us to 1 million Mozillians? :-P

Please don't push that version live. I think it would be better to remove it entirely from the page than to have that big banner.

Comment 40

4 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #35)
> (In reply to Verdi [:verdi] from comment #34)
> > Created attachment 824194 [details]
> > You mean up there with log in and stuff - like this attachment? I LOVE that
> > idea. That could go on all pages.
> 
> That's cool but there isn't enough space when logged in, especially in other
> languages:
> 
> http://cl.ly/image/14353z433p3U

If you are logged in an not a contributor it should take the place of contributor tools. If you are a contributor then there is no reason to show it. That should make enough room.
(In reply to Verdi [:verdi] from comment #40)
> If you are logged in an not a contributor it should take the place of
> contributor tools. If you are a contributor then there is no reason to show
> it. That should make enough room.

Works in theory, but many of us legacy users aren't in that contributor group so we'd have to go through and join. A little annoyance or confusion?

Anyway, we can work on adding something to the header in a separate bug. Let's get this home page done.

Comment 42

4 years ago
As the copy and IA champion I think we should remove both the big get involved banner and the news section and call this done.

Comment 43

4 years ago
I, for one, want to propose an in-between solution: Can we keep the art-work but reduce the copy of Safe The World to reduce the weight of the CTA?

- /home receives few visits compare to the /products/xxxx
- The main navigation is still the products. For low resolutions, the Safe The World messaging is below the fold.
- Keeping this for one extra day could give us some valuable data on how much can we affect the traffic to this site.

Adding some extra visibility to the Get Involved page is always desirable, when done it right.
Closing this out in favor of bug 932539
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Depends on: 932539

Comment 45

4 years ago
We've removed the link to the archived article (suggestion box section) from the desktop version of the start page but we have not removed it from the mobile version so I'm reopening it.

In the process of working out what to do to fix this bug we have experimented with a few approaches to solve new issues brought up by removing the suggestion box section. One of those approaches was to make the news items take up the full width of the page. Another was to increase the size of the get involved CTA to compensate for the increased size of the news items. Neither of these solutions are appropriate as I've argued in this bug. I've filed bug 932539 to have them both removed.

In addition, I've filed bug 932471 as a sensible solution to the removal of the get involved CTA.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pull request to remove link from mobile:

https://github.com/mozilla/kitsune/pull/1705
This bug is a great example of scope creep. We started out just wanting to remove a link from the desktop home page and the mobile sidenav. And we've ended up.... here

Comment 48

4 years ago
I agree with Ibai on this. I think the get involved banner is awesome. I would love to have it on the home page and see if this drives our contributor sign-up up.
Landed the mobile removal on master:
https://github.com/mozilla/kitsune/commit/813c25676c7e98227612b8b38e7f20e567a612e1
Deployed to prod. "Suggestion Box" link is gone from both desktop and mobile pagesnow.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
No longer depends on: 932539

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.