[Dialer] "No calls recorded" prompt disappears for missed call if there are only answered call logs

RESOLVED DUPLICATE of bug 883131

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 883131
4 years ago
4 years ago

People

(Reporter: rexboy, Assigned: rexboy)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(1 attachment)

Created attachment 783060 [details]
Screenshot

STR:
0. Open dialer app.
1. Make sure there are no call logs.
2. Make an outcoming call and hang up.
3. Go to call log page > Missed
Excepted:
The "No calls recorded" prompt shows
Actual:
The missed call tab is shown in blank

See screenshot. This should be just an UI tweak, but a blank screen is somewhat confused.
blocking-b2g: --- → leo?
This sounds like a regression hence leo+, Adding qa to confirm.
blocking-b2g: leo? → leo+
Keywords: regression
Flags: needinfo?(anthony)
Needinfo is for you to check if this belongs in your team.
This seems to be the same issue as for bug 899892, see my comment there.

In short, the patch for bug 883131 (which landed on master almost 2 weeks ago) fixes this, however, since it was not leo+, the issue highlighted here is not fixed on v1-train.

Updated

4 years ago
Duplicate of this bug: 899892
Assignee: nobody → rexboy
Based on comment 3, marking as duplicate.

I'll request leo+ in bug 883131 to fix this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(anthony)
Resolution: --- → DUPLICATE
Duplicate of bug: 883131
You need to log in before you can comment on or make changes to this bug.