[FTU][Helix][HD] "Import" frame (for Facebook, etc.) is not sized correctly on v1.1.0hd

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rexboy, Assigned: rexboy)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:hd+, b2g-v1.1hd fixed, b2g-v1.2 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 783071 [details]
Screenshot

STR:
1. in FTU, Proceed to "Import contacts" Page. Make sure data transfer or Wifi is connected.
2. Tap "Facebook"
Excepted:
Facebook login frame occupies the whole screen
Actual:
There's a slim space under the frame that user can still see the FTU button.
See screenshot.
blocking-b2g: --- → hd?
Summary: [FTU][Helix][HD] "Import" frame (for Facebook, etc.) is not in full screen on v1.1.0hd → [FTU][Helix][HD] "Import" frame (for Facebook, etc.) is not sized correctly on v1.1.0hd
Created attachment 783748 [details]
Patch

A simple patch that just changes CSS.
Since the style in BB of action menu doesn't guarantee the inner ul element stretch to just fit the space between title and button, I have to subtract the height of title and button by myself. But this should guarantees the list fits the space (as long as BB doesn't change its height of title and button).

German may you take a look on this patch? thanks a lot!
Attachment #783748 - Flags: review?(gtorodelvalle)
Oops.
Sorry, forget comment 1. That was for bug 899501.
I just got lost on tabs of bugs :-/
Attachment #783748 - Flags: review?(gtorodelvalle)
Attachment #783748 - Attachment is obsolete: true
HD+ UI bug
blocking-b2g: hd? → hd+
Created attachment 786241 [details]
Patch

I guess the problem comes from the order of initializing a new popup window
(See the patch)

Furthermre, seems it's 100% reproducible only when I open FTU from developer mode.

It's just a very simple change, but this is quite an old piece of code
that no one have ever modified for about 10 months.
Alive may you take a look on it? Hope I'm not doing things wrong.
Attachment #786241 - Flags: review?(alive)
Comment on attachment 786241 [details]
Patch

Basically r+
But does this occur in master? It's strange that only hd has this issue.
Attachment #786241 - Flags: review?(alive) → review+
And test these:
* Rotate (Use UI test)
* App Switch
* Keyboard
Thank you Alive. After updating the repository I found it occurs in master too.
So this isn't a hd-only issue.. though I can't reproduce it very stably.
Well, I guess then, I may have to nominate it as leo? .. 
Let me do further check you mentioned.

master:
https://github.com/rexboy7/gaia/commit/756403029210ce70efaa8946ea946ea5b85115bb

If I found something wrong I'll reopen it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v1.1hd: --- → affected
status-b2g-v1.2: --- → affected

Comment 8

4 years ago
Per offline discuss with Rex, we'll need the patch for v1.1hd and v1.2.

Updated

4 years ago
Keywords: checkin-needed
v1.1.0hd
https://github.com/mozilla-b2g/gaia/commit/63cd1d96b5a94e9b22ffc54dfde48ef6d3cf996b

v1.2 already have this patch so I don't need to uplift it.
status-b2g-v1.1hd: affected → fixed
status-b2g-v1.2: affected → fixed
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.