selection jitters adjacent text

RESOLVED WORKSFORME

Status

()

Core
Selection
P4
minor
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Christopher Lam, Assigned: mjudge)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2+) Gecko/20010708
BuildID:    2001070808

When using a font which does not have a bold version, and using <strong>,
Windows (or the GTK) simulates the bold by drawing the text twice, offset by 1px
presumably.

However selection of the emboldened-text causes the surrounding text to jitter a
bit, presumably because of the 1px miscalculation somewhere.

Try the testcase, using the font "Arial Black" or any font without a bold
counterpart.

Reproducible: Always
Steps to Reproduce:
1.Load attached testcase (is HTML 4.01 compliant <g>)
2.Select some text
3.Watch the text

Actual Results:  Jitter

Expected Results:  No jitter
(Reporter)

Comment 1

17 years ago
Aww shucks. I can't attach a file. Here is the source:

-----begin testcase.html-----
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head><title></title></head>
<body><font face="Arial Black"><strong>
Start highlighting and watch the text jitter.</strong></font>
<p><i><a href="http://validator.w3.org/check/referer"><img border="0"
src="http://www.w3.org/Icons/valid-html401" alt="Valid HTML 4.01!" height="31"
width="88">
</a>
</i></p>
</body>
</html>
-----end testcase.html-----

Comment 2

17 years ago
future
Severity: normal → minor
Priority: -- → P4
Target Milestone: --- → Future

Comment 3

14 years ago
Christopher, this works for me on WinXP. I have Arial Black and have no bold
version of it. Still no jitter.
Do you still see this?
(Reporter)

Comment 4

14 years ago
Can't reproduce. Probably fixed now. Let's close and clean up. (It's been 3 years!)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.