firefox lacks tibetan in list-style-type

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Elie Roux, Unassigned)

Tracking

(Depends on: 1 bug)

22 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 783122 [details]
Simple test file

Can you please add tibetan as a working entry for list-style-type? According to http://www.w3.org/International/tests/html-css/list-style-type/results-list-style-type it works for Webkit, and it would be extremely useful for Tibetan websites!

I tested on http://www.w3.org/International/tests/html-css/generate?format=h5&test=list-style-type-022, and also in the attached file. The result is that the item numbers are in latine characters, while they should be in Tibetan characters (as in the second column). On https://developer.mozilla.org/en-US/docs/Web/CSS/list-style-type it indeed doesn't list tibetan as a valid argument for list-style-type.
(Reporter)

Comment 1

4 years ago
Note that I would be ready to provide a proposal of patch, but I'm unable to compile firefox (too old computer...). If someone is ready to test an untested patch, I'm ready to provide it!
Attachment #783122 - Attachment mime type: text/plain → text/html
It looks like the most recent spec this is defined in is here:
  http://www.w3.org/International/docs/counter-styles/
which provides author and/or UA-usable "@counter-style" markup to add support for list-style-type: tibetan.

@counter-style is specced here:
  http://dev.w3.org/csswg/css-counter-styles-3/
and it appears we don't support it yet -- bug 843718 tracks that.
Depends on: 843718

Comment 3

4 years ago
Right, the huge laundry list of predefined counter styles [1] has been moved to a simple list maintained by the W3C Internationalization group.  Once the Counter Styles spec is done you'll be able to define 'tibetan' list counters using that.

[1] http://www.w3.org/TR/2011/WD-css3-lists-20110524/#ua-stylesheet
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

4 years ago
Thank you very much for your answers! I just have one question, not 100% related: I'd like to implement alphabetical lists for tibetan (not as straightforward as other languages). Is it possible to propose it to the w3c as an individual if I have an official specification from the most eminent Tibetan language association?

Comment 5

4 years ago
Elie, the point of the Counter Styles spec is that the author can define the list-style themselves rather than trying to have the W3C standardize it.  Additionally, there isn't the need to define a *single* pattern to associate with a given name.  This also avoids the CSS WG having to discuss matters that most members aren't familiar with (search in the archives for the long discussions of Armenian numbering schemes for an example of this).

Look over the Counter Styles spec.  If the functionality there isn't enough to capture how to do the list style for Tibetan that you want then propose the features you think are needed to the www-style mailing list.
You need to log in before you can comment on or make changes to this bug.