Can't run mach mochitest-plain: 'TypeError: __init__() takes at most 2 arguments (3 given)'

RESOLVED DUPLICATE of bug 898725

Status

RESOLVED DUPLICATE of bug 898725
5 years ago
6 months ago

People

(Reporter: joe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
$ mach mochitest-plain
Error running mach:

    ['mochitest-plain']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

TypeError: __init__() takes at most 2 arguments (3 given)

  File "/src/mozilla-central/testing/mochitest/mach_commands.py", line 268, in run_mochitest_plain
    return self.run_mochitest(test_file, 'plain', **kwargs)
  File "/src/mozilla-central/testing/mochitest/mach_commands.py", line 299, in run_mochitest
    **kwargs)
  File "/src/mozilla-central/testing/mochitest/mach_commands.py", line 111, in run_mochitest_test
    opts = mochitest.MochitestOptions(automation, tests_dir)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898725

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.