color picker doesn't show correct color on chip or editfield

VERIFIED FIXED in mozilla0.9.3

Status

()

Core
Editor
--
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Kathleen Brade, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed, reviewed, nsBranch+, PDT+)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
In Composer the color picker doesn't show the correct color on the color chip on 
the toolbar.  Also, the editfield doesn't always show a value when it should.

To reproduce:
  type some text in Composer
  select the text
  choose the text color picker
  enter: #eeeeee
  click ok
Notice that the color picker shows a white color chip but the text is a very 
light gray.  
  go back to color picker
Notice that the edit field is empty; it should show "#eeeeee"
(Assignee)

Comment 1

17 years ago
This problem occurs when the color typed in is *not* in the array of color
swatches.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

17 years ago
This bug occurs because of recent change in how color picker is intialized.
We should call "initColor()" else we can't use a color that isn't in the 
color swatch array! (Not a good thing.)
Fix is very simple. Nominating to fix for 6.1.

r=sfraser
Severity: normal → major
Whiteboard: fixed, need sr=
Target Milestone: mozilla1.0 → mozilla0.9.3
(Assignee)

Comment 3

17 years ago
Created attachment 41829 [details] [diff] [review]
Fix initialization of colorpicker color
(Assignee)

Comment 4

17 years ago
Per discussion with beppe, setting nsBranch.
Keywords: nsBranch

Comment 5

17 years ago
sr=kin@netscape.com
Whiteboard: fixed, need sr= → fixed, reviewed

Comment 6

17 years ago
I didn't r= this yet. I said I *would*, not that I *had*
Hardware: Macintosh → All

Comment 7

17 years ago
ok, r=sfraser
(Assignee)

Comment 8

17 years ago
checked into trunk.
Keywords: vtrunk

Comment 9

17 years ago
adding nsBranch+
Whiteboard: fixed, reviewed → fixed, reviewed, nsBranch+
(Assignee)

Comment 10

17 years ago
PDT+ approved by Steve Elmer.
Whiteboard: fixed, reviewed, nsBranch+ → fixed, reviewed, nsBranch+, PDT+
(Assignee)

Comment 11

17 years ago
Checked into branch
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
verified on 7/11 trunk.

now I will verify on the branch.

removing vtrunk keyword
Keywords: vtrunk

Comment 13

17 years ago
verified on 7/13 branch on windows.

marking verified-fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.