Complete uninstall does not remove directory C:\Program Files\Mozilla Firefox

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: gpk66, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

I recently (remotely) helped a friend to get rid of some malicious add-ons, primarily the v9.com search redirector. (See http://malwaretips.com/blogs/v9-portal-site-removal/) 

I tried a few quick fixes, which didn't work, but eventually did a complete uninstall of Firefox then reinstalled it.


Actual results:

The same malicious add-ons were present after the reinstall. After some more troubleshooting, I discovered that most of the directory structure at "C:\Program Files \Mozilla Firefox" was left intact after a complete uninstall.

After doing another complete uninstall, manually removing the leftover directory structure, and reinstalling FF, I finally got a clean install without the malicious add-ons.


Expected results:

If I do a complete uninstall, I'd expect that the installation directory structure would be completely removed.

Is the directory structure left in place for some reason, to speed up reinstallation perhaps ? If it is, then I think it's an erroneous assumption, and the entire directory structure should be wiped.

If I do a complete uninstall, I want my directory structure to be the same as if I had never installed the program in the first place. Leaving remnants of the previous installation behind after a complete uninstall can cause annoying problems with a subsequent reinstallation.
(Reporter)

Comment 1

5 years ago
Note: My friend has a Windows XP PC, but I entered the bug from my Win 7 PC, so the bug specs are for my PC. However, I believe this is a problem regardless of which version of Firefox in being completely uninstalled.
>If I do a complete uninstall, I'd expect that the installation directory structure 
>would be completely removed.

The Firefox uninstaller removes only files that the installer put in that directory.
The directory can not be removed if there are third-party files present that other applications installed there. 

Note: Extensions are in most cases installed in the users home directory and are only removed if you enable the special checkbox (something like "delete private data") during the uninstall.

I see nothing in this report that would be a bug marking invalid (= not a bug)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.