Unable to purchase applications "Price point unavailable for this region or carrier" (Seahorse)

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rodrigo.karuki, Assigned: Keir Kettle, NeedInfo)

Tracking

Points:
---
Bug Flags:
affects-seahorse +

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 783407 [details]
LOG

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1. Start Marketplace
2. Search for a paid application
3. Select to purchase
4. Enter PIN



Actual results:

The message "Price point unavailable for this region or carrier" (or "El rango de precio no está disponble para esta región o este operador", in Spanish) is displayed and it is not possible to purchase the app.


Expected results:

The application payment screen should be displayed without any error.
(Reporter)

Comment 1

5 years ago
Created attachment 783409 [details]
2013-07-30-18-02-04-tier unavailable-spanish.png
(Reporter)

Comment 2

5 years ago
Created attachment 783410 [details]
2013-07-30-18-05-07-tier unavailable-english.png

Comment 3

5 years ago
Can i clarify the region is set to the correct region for Seahorse right? Is this in Stage?
Assignee: nobody → keir

Comment 4

5 years ago
That is because you got a Country Mismatch error three times and Credit Card was blocked as a payment option which means you are then stuck for payment options. Card unblocked.
(Reporter)

Comment 5

5 years ago
The region is set correct (and now Marketplace already sets it right).
So how can we avoid this country mismatch error?
Karina is using the hotel wifi and it has an IP from US. But it's not 100% of the times that she sees this message. Plus, she was the one that could do all of the purchases on Friday.
I'm taking a new log only using 2G, that we shouldn't have any problems with region.
(Reporter)

Comment 6

5 years ago
Created attachment 786464 [details]
New log. Only in 2G
Tom,

this last error had

BillingConfigurationId=27634630
Network=VEN_MOZILLA
ResponseCode=NOT_SUPPORTED

Can you tell us why they are getting a country mismatch error? What country is geoIP resolving to in this case? Since the testers are now using international credit cards why is this a country mismatch error anyway?
you can find whoami info from these devices in bug 900140
(Assignee)

Comment 9

5 years ago
(In reply to Kumar McMillan [:kumar] from comment #7)
> Tom,
> 
> this last error had
> 
> BillingConfigurationId=27634630
> Network=VEN_MOZILLA
> ResponseCode=NOT_SUPPORTED
> 
> Can you tell us why they are getting a country mismatch error? 

Because the BIN info supplied by our card processor says the card (ending in 8722) is registered in GBR, and the users country is VEN.

> What country is geoIP resolving to in this case? 

I think the country check is based on the users country (VEN) as opposed to the client IP.  Even so the client IP for the BCID you asked about was 181.184.237.69 which looks to be VEN too. 

>Since the testers are now using international credit cards why is this a country mismatch error anyway?

As above, BIN lookup on the card number != users country.

Comment 10

5 years ago
Keir, so i understand the issue with the BIN numbers but what I don't understand is why this isn't consisted as I can use a UK issued € card to by apps in Durango.

I also don't see how the "Pricepoint unavailable for this region or carrier" is generated by that as the Credit card hasn't been entered at this point
Flags: needinfo?(keir)
(Assignee)

Comment 11

5 years ago
(In reply to Steve Ruston from comment #10)
> Keir, so i understand the issue with the BIN numbers but what I don't
> understand is why this isn't consisted as I can use a UK issued € card to by
> apps in Durango.

Has Tom changed your account type?

> I also don't see how the "Pricepoint unavailable for this region or carrier"
> is generated by that as the Credit card hasn't been entered at this point

This is a Mozilla screen, which you display when we return "NOT_SUPPORTED".  We can look to return a better status code.
Flags: needinfo?(keir)

Comment 12

5 years ago
Is this fixed? Keir changed a few accounts the other day.
Flags: needinfo?(rodrigo.karuki)
Flags: affects-seahorse+

Updated

5 years ago
Priority: -- → P2

Comment 13

5 years ago
I think this is fixed with the change to account type.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.