"GitHub Status" logo png is very pixelated after image is resized

RESOLVED DUPLICATE of bug 897532

Status

()

RESOLVED DUPLICATE of bug 897532
5 years ago
5 years ago

People

(Reporter: cpeterson, Assigned: jrmuizel)

Tracking

({regression})

unspecified
regression
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25+ fixed)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
STR:
1. Open https://status.github.com/
2. See that the "GitHub Status" logo looks very pixelated

This is a regression in Nightly 25 build 2013-07-23. Here is the pushlog from build 07-22 and 07-23:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2268ff80683a&tochange=5ceea82a79c7
(Reporter)

Comment 1

5 years ago
Created attachment 783428 [details]
Screenshot_2013-07-22_good.png

Good screenshot from build 07-22.
(Reporter)

Comment 2

5 years ago
Created attachment 783429 [details]
Screenshot_2013-07-23_bad.png

Bad screenshot from build 07-23.

* Nick: could this pixelated image bug be a regression from your image resizing bug 700926? Your patch is within the pushlog regression range.
Flags: needinfo?(ncameron)
(Reporter)

Updated

5 years ago
Keywords: regression

Comment 3

5 years ago
Not sure I am repro'ing this correctly, but it does seem to be due to 700926, and it also seems to be fixed by the patch I'm working on for 897787. But lets not dup this bug until we confirm that.
Flags: needinfo?(ncameron)

Comment 4

5 years ago
(In reply to Nick Cameron [:nrc] from comment #3)
> Not sure I am repro'ing this correctly, but it does seem to be due to
> 700926, and it also seems to be fixed by the patch I'm working on for
> 897787. But lets not dup this bug until we confirm that.

Nope on second look, it appears I just can't repro this bug with latest nightly. Tried on Windows and Linux. I always see the good version.
(Reporter)

Comment 5

5 years ago
I can repro with the latest Nightly (07-30) on my MacBook Pro.

Comment 6

5 years ago
Well, I did what I should have done at first and checked the source code - turns out it is an img element, not a background-image, so it is highly unlikely that this regression is due 700926.

Do you have a retina screen? If so, perhaps it is a retina scaling bug?
(Reporter)

Comment 7

5 years ago
No, I have a non-Retina screen.
(Reporter)

Comment 8

5 years ago
Interestingly, on my Retina MacBook at home, the image is NOT pixelated (unless I manually disabled HiDPI with gfx.hidpi.enabled=-1).
Flipping gfx.content.azure.enabled to false seems to fix this, so this is probably caused by bug 896489.
Blocks: 896489
Component: Layout: Images → Graphics
This is because we don't have high quality image scaling enabled in the CoreGraphics moz2d backend, JEFF MUIZELAAR!!!
Assignee: nobody → jmuizelaar
tracking-firefox25: --- → ?
tracking-firefox25: ? → +
(Reporter)

Comment 11

5 years ago
Created attachment 790461 [details]
DemetriMartin_twitter_avatar.png

This bug also caused Twitter avatar images, particularly ones with white backgrounds, to have have fuzzy pixel artifacts on their edges. See the attached screenshot.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 897532

Updated

5 years ago
status-firefox25: affected → fixed
You need to log in before you can comment on or make changes to this bug.