Marketplace update on Geeksphone Keon Fails

RESOLVED WORKSFORME

Status

Firefox OS
Gaia
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: feer56, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 783504 [details]
Marketplace update issue

Request for update check. Check done and shows with Marketplace update (notification bar shows 1 update available, tap  on it). I choose to install. Once download is complete, it disappears from notification bar. Nothing else happens. Marketplace app cannot be opened anymore; tapping on it provides no action. Must reboot in order to get it to work. 

New logs attached. (Spoke to :jsmith on #qa earlier where nothing could be determined from earlier logs, hope these new logs and description above will lead to new leads.)
Flags: needinfo?(jsmith)
CC Naoki on this as well.
Flags: needinfo?(nhirata.bugzilla)
Okay, so these logs definitely look right. I'm seeing the update check happening. I'm also seeing that the app update is being found:

I/Gecko   ( 1733): UpdatePrompt: appsUpdated: 1 apps to update

comment 0 actually indicates something a bit different than what I understood in IRC - the update completes, but the app can't be launched. That raises a few followup questions then:

1. What build are you testing this on? 1.01? 1.1?

2. After you reboot the device, try checking for updates again. Do you end up finding an update available for marketplace?
Flags: needinfo?(jsmith)
(In reply to Jason Smith [:jsmith] from comment #2)
> Okay, so these logs definitely look right. I'm seeing the update check
> happening. I'm also seeing that the app update is being found:
> 
> I/Gecko   ( 1733): UpdatePrompt: appsUpdated: 1 apps to update
> 
> comment 0 actually indicates something a bit different than what I
> understood in IRC - the update completes, but the app can't be launched.
> That raises a few followup questions then:
> 
> 1. What build are you testing this on? 1.01? 1.1?
> 
> 2. After you reboot the device, try checking for updates again. Do you end
> up finding an update available for marketplace?

Sorry if I wasn't clear on IRC. 
Geeksphone Keon 1.0.1.0-prerelease
After reboot I do find an update available for the marketplace.
Hmm...that's quite an old build then. On my 1.1 build, this works for me when I last tested a marketplace update.

Not sure what we can do here. Can you try testing this on a 1.1 Keon build?
What known issues are there in 1.1?
Can I get clarity in what you are looking for in asking the known issues?  The known issues are listed in bugzilla, doing a search on either leo, 1.1HD or koi would probably find most of the issues if not all.
Flags: needinfo?(nhirata.bugzilla)
I did another installation for this update along with a HERE Maps update and the update went through successfully. No notifications for updates.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.