Closed Bug 899880 Opened 6 years ago Closed 6 years ago

Bug 898558 broke building with --enable-replace-malloc and building with jemalloc3.

Categories

(Core :: Memory Allocator, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: glandium, Unassigned)

References

Details

Attachments

(1 file)

The mozjemalloc compatibility layer was not updated, so it fails to compile.
Duplicate of this bug: 900336
This breaks --enable-dmd, among other things:

22:56.43 /home/njn/moz/mi0/memory/build/mozjemalloc_compat.c:81:10: error: no member named 'dirty' in 'jemalloc_stats_t'
22:56.43   stats->dirty = pdirty * page;
22:56.43   ~~~~~  ^
22:56.43 /home/njn/moz/mi0/memory/build/mozjemalloc_compat.c:82:10: error: no member named 'committed' in 'jemalloc_stats_t'
22:56.43   stats->committed = active + stats->dirty;
22:56.43   ~~~~~  ^
22:56.43 /home/njn/moz/mi0/memory/build/mozjemalloc_compat.c:82:38: error: no member named 'dirty' in 'jemalloc_stats_t'
22:56.43   stats->committed = active + stats->dirty;
Attached patch Patch, v1Splinter Review
Attachment #784641 - Flags: review?(mh+mozilla)
Sorry for the bustage, everyone.
Duplicate of this bug: 899126
Comment on attachment 784641 [details] [diff] [review]
Patch, v1

Review of attachment 784641 [details] [diff] [review]:
-----------------------------------------------------------------

Typo in the commit message.
Attachment #784641 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/25fa0d94a507
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
All good on my end now too, thanks for the quick fix!
Duplicate of this bug: 899446
You need to log in before you can comment on or make changes to this bug.