All users were logged out of Bugzilla on October 13th, 2018

[Dialer] Missed call info is not displayed in Call log for special case (detail in description).

RESOLVED DUPLICATE of bug 899506

Status

RESOLVED DUPLICATE of bug 899506
5 years ago
5 years ago

People

(Reporter: echu, Assigned: mihai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(1 attachment)

9.73 MB, video/mp4
Details
(Reporter)

Description

5 years ago
Created attachment 783555 [details]
video

When there is no missed call record but other records are in All tab of call log, and user opens Missed tab then exit call log/dialer, a new missed call record will not be displayed on Missed tab until tapping All tab first.(You can watch video for much clear information.)

v1.1 Leo has same problem.

* Build Number                
Gaia:     f2bc4a004f592cd6dce4edda2b0533f4fd4f91f2
  B-D     2013-07-25 18:32:32
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/2bb08f2878da
BuildID   20130725070202
Version   18.1

* Reproduce Steps
1. Make sure only records in All tab, not in Missed tab in Call log page.
2. Stay in Missed tab, then exit call log page.
3. Dial in a call and do not answer it.
4. Go to Call log again, it will open Missed tab without new record on it.

* Expected Result
New record should be displayed.

* Actual Result
No record until opening All tab first and back to Missed tab.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
(In reply to echu from comment #0)

> 
> v1.1 Leo has same problem.
> 

Bumping to leo?
blocking-b2g: hd? → leo?
This sounds like a regression hence leo+.Also adding qawanted to confirm.
blocking-b2g: leo? → leo+
Keywords: regression
Anthony,

Please add assignee as this belongs in the Dialer team
Flags: needinfo?(anthony)
I can take this if Anthony is fine with it since I worked on the call log tabs logic.
This does not reproduce on latest master (4154883) and the reason is that the patch for bug 883131 adds the logic to always show the 'All' tab when a new call is recorded, regardless if it's missed or not -- no regression seems to happen here (if you still observe it on master, it might be the case that your call log entries were part of an older call_log_db version, so simply reset-gaia and check again)

On v1-train (d98a106) however, there is no logic for properly updating the call log tabs -- the missed call tab doesn't even have its own empty log message. All of this happens since bug 883131 was not leo+ and the respective patch was not uplifted.

Adding qawanted to double check my claims, and to fix this I think uplifting the patch from bug 883131 should be sufficient.
Keywords: regression → qawanted
(Assignee)

Updated

5 years ago
Assignee: nobody → mihai
(Reporter)

Updated

5 years ago
Keywords: qawanted
(Reporter)

Comment 6

5 years ago
Duplicate with bug 899506.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 899506

Updated

5 years ago
Flags: needinfo?(anthony)
You need to log in before you can comment on or make changes to this bug.