Try and preserve differences in text colors when switching to Reader Mode

RESOLVED WONTFIX

Status

()

Firefox for Android
Reader View
--
enhancement
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Samsung Galaxy R (Android 2.3.4) 
Firefox Mobile 23 RC / Nightly 25.0a1 2013-07-29

Steps to reproduce:
1) Load an article with different text colors (http://www.surrenderat20.net/2013/07/patch-310-notes.html#more for e.g)
2) Enter reader mode

Actual result:
All text is black

Notes:
On some pages/articles different font colors (red in the link provided) may be used to highlight important things. We should try and keep the difference in text color when switching to reader mode. This would improve the Reader Mode experience and keep the intention of pointing out areas of the text as important.
Readiblity.com makes that page completely uniform as well. Maintaining these sorts of css rules would make the code even more complicated. 

Wontfix?
Flags: needinfo?(lucasr.at.mozilla)
Flags: needinfo?(ibarlow)
Yeah... I'm not sure we want to get into preserving changes that are unique to a specific website's css, both because that could get very complex/ugly very quickly, and also because colours defined by a particular website won't always work across  Reader Mode's light *and* dark backgrounds.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ibarlow)
Resolution: --- → WONTFIX

Updated

4 years ago
Flags: needinfo?(lucasr.at.mozilla)
You need to log in before you can comment on or make changes to this bug.