jsapi-test/testRegExpInstanceProperties.cpp is not compiled

RESOLVED FIXED in Firefox 39

Status

()

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jonco, Assigned: jonco)

Tracking

unspecified
mozilla39
Points:
---

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
As discovered in bug 896949, this file was removed from the build, but not version control, with the following change:

Bug 648355 - Disable a fragile JSAPI test that seems to have been kicked into failure likely by compiler-determined optimizations, or something similarly undefined and maybe now impossible to rely upon -- but we'll see. For now, just return to green and really deal with it later. r=orange

author	Jeff Walden <jwalden@mit.edu>
	Fri Apr 08 15:24:00 2011 -0700 (at Fri Apr 08 15:24:00 2011 -0700)

The bug number is wrong though.

The code as it stands doesn't compile.
(Assignee)

Comment 1

5 years ago
Jeff, do you remember what the problem was this test caused?  Do you think this test is worth fixing or should we just remove it?
Flags: needinfo?(jwalden+bmo)

Comment 2

5 years ago
Remove it.  ES6 last I heard made all the RegExp instance data properties into accessor properties on RegExp.prototype, which would eliminate the mess of complexity this test was designed to exercise.  So there's no good reason for it any more once we make that change.  I tend to think, for consistency, we should make that change before removing this test file.  It shouldn't be too bad, possibly may even let us kill off current RegExp complexity that'll no longer be needed once those properties are accessorized.
Flags: needinfo?(jwalden+bmo)
(Assignee)

Updated

5 years ago
Depends on: 886976
Assignee: general → nobody
(Assignee)

Comment 3

4 years ago
Created attachment 8569759 [details] [diff] [review]
bug899979-remove-unused-test-code

This change seems to have happened now in bug 1120169, so removing the file.
Assignee: nobody → jcoppeard
Attachment #8569759 - Flags: review?(jwalden+bmo)

Updated

4 years ago
Attachment #8569759 - Flags: review?(jwalden+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/4fe43cd0ac7d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.