Closed Bug 899991 Opened 7 years ago Closed 7 years ago

"TypeError: profile is undefined: Sidebar.prototype<.getItemByProfile@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/profiler/sidebar.js:91"

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P2)

x86_64
macOS
defect

Tracking

(firefox24 unaffected, firefox25 fixed, firefox26 fixed)

RESOLVED FIXED
Firefox 26
Tracking Status
firefox24 --- unaffected
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: emorley, Assigned: anton)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qa-])

A recently deployed TBPL parser improvement has found a whole bunch of log spam in green debug mochitest-browser-chrome runs.

a) Should these be making the test run fail?
b) We should handle/fix, so we don't spam the annotated failure summary.

eg:
https://tbpl.mozilla.org/php/getParsedLog.php?id=25965644&tree=Mozilla-Inbound#error1

{
04:30:25     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/profiler/test/browser_profiler_console_api_content.js
04:30:25     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/profiler/test/browser_profiler_console_api_content.js |
04:30:25     INFO -  TypeError: profile is undefined: Sidebar.prototype<.getItemByProfile@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/profiler/sidebar.js:91
}

http://hg.mozilla.org/mozilla-central/file/c2b375f3a909/browser/devtools/profiler/sidebar.js#l91
{
    90   getItemByProfile: function (profile) {
    91     return this.getItemByValue(profile.uid.toString());
    92   },
}
Flags: needinfo?(anton)
Blocks: 892958
Duplicate of this bug: 902382
(In reply to Ed Morley [:edmorley UTC+1] from comment #0)
> A recently deployed TBPL parser improvement has found a whole bunch of log
> spam in green debug mochitest-browser-chrome runs.
> 
> a) Should these be making the test run fail?

Yes! In fact, I always assumed that exceptions *do* make tests fail and thus never bothered to look at logs when the run is green.

> b) We should handle/fix, so we don't spam the annotated failure summary.

https://hg.mozilla.org/integration/fx-team/rev/b3458cc385aa (r=me since the change is in tests only)
Flags: needinfo?(anton)
Whiteboard: [fixed-in-fx-team]
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/b3458cc385aa
Assignee: nobody → anton
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
No longer blocks: 892958
Blocks: log-SnR
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
Blocks: 920191
No longer blocks: log-SnR
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.