Don't work arrow key on location bar when using autocomplete address

VERIFIED FIXED

Status

()

Firefox
Address Bar
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tetsuharu, Assigned: Away for a while)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25+ verified)

Details

[Environment]
* http://hg.mozilla.org/mozilla-central/rev/c2b375f3a909
* OS X 10.8

[Step To reproduce]
1. Focus location bar.
2. Type some words to lookup history or bookmarks.
3. Display drop down list of matched entries.
4. Input up/down key.

[Result]
* Drop down list will flash. (Is this caused with updating matched entries?)
* I cannot walk across suggested entries.
* Focus is staying on location bar input field if I input up/down key repeatedly.
(Reporter)

Updated

4 years ago
Keywords: regression
(Assignee)

Updated

4 years ago
status-firefox25: --- → ?
tracking-firefox25: --- → ?
Keywords: regressionwindow-wanted
This affects all form input drop downs, not just the location bar's.

Comment 2

4 years ago
Regression-hunted this, caused by bug 893973, verified by a local backout against m-c tip. Masayuki, I think we may want to back out considering how many people are affected...
Blocks: 893973
Flags: needinfo?(masayuki)
Keywords: regressionwindow-wanted
status-firefox25: ? → affected
> Regression-hunted this, caused by bug 893973

I assume you're referring to this patch:  attachment 778350 [details] [diff] [review] ("nsIWidget::SetInputContext() should check it has focus before calling secure event input API")
(Assignee)

Comment 4

4 years ago
(In reply to Steven Michaud from comment #3)
> > Regression-hunted this, caused by bug 893973
> 
> I assume you're referring to this patch:  attachment 778350 [details] [diff] [review]
> [review] ("nsIWidget::SetInputContext() should check it has focus before
> calling secure event input API")

No, I believe it's https://hg.mozilla.org/mozilla-central/rev/197b12188f3a.  Steven, do you mind logging in to IRC if possible?

Comment 5

4 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #4)
> (In reply to Steven Michaud from comment #3)
> > > Regression-hunted this, caused by bug 893973
> > 
> > I assume you're referring to this patch:  attachment 778350 [details] [diff] [review]
> > [review] ("nsIWidget::SetInputContext() should check it has focus before
> > calling secure event input API")
> 
> No, I believe it's https://hg.mozilla.org/mozilla-central/rev/197b12188f3a. 
> Steven, do you mind logging in to IRC if possible?

Correct. Backing that out fixes it.
Sigh, go ahead.

I can't imagine why that patch causes trouble, but I'll figure that out later.
(Assignee)

Comment 7

4 years ago
I backed out the offending patch: https://hg.mozilla.org/mozilla-central/rev/fd03bb4d1e48
Assignee: nobody → ehsan
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Flags: needinfo?(masayuki)
Duplicate of this bug: 900544

Updated

4 years ago
status-firefox24: --- → unaffected
tracking-firefox25: ? → +

Updated

4 years ago
status-firefox25: affected → fixed
Keywords: verifyme
Reproduced in nightly 2013-07-31. Verified fixed FF 25b3 Mac OS X 10.8.4
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.