crash in mozalloc_abort(char const* const) | xul.dll@0xcf3970 | xul.dll@0x700c93 | xul.dll@0x5327bd | xul.dll@0x190797 | xul.dll@0x1ae01d | js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct)

RESOLVED DUPLICATE of bug 767343

Status

()

Core
XUL
--
critical
RESOLVED DUPLICATE of bug 767343
5 years ago
5 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({crash, regression})

24 Branch
x86
All
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-12855b22-ce69-4a37-a52d-ba7b32130731 .
 ============================================================= 

This crash has appeared on explosiveness reports for Fx 23. It's #21 on top crash list. However, the reports are for 20130725195523 (beta7) only.  There doesn't appear to be crashes of this signature with more recent betas (8, 9 or 10).

There is a  similar crash that appears on Aurora (Fx24) for build of 20130729004005.  that's https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=7&range_unit=days&date=2013-07-31&signature=mozalloc_abort%28char+const*+const%29+|+xul.dll%400xddf92d+|+xul.dll%400x8976a2+|+xul.dll%400x6a0558+|+xul.dll%400x223df6+|+xul.dll%400x20173b+|+js%3A%3AInvoke%28JSContext*%2C+JS%3A%3AValue+const%26%2C+JS%3A%3AValue+const%26%2C+unsigned+int%2C+JS%3A%3AValue*%2C+JS%3A%3AValue*%29&version=Firefox%3A24.0a2 But no reports with more recent builds.

Not sure if this is still valid, but filing the bug to track it.

No URL's stand out; just a plethora of various one crash per page.

0 	mozalloc.dll 	mozalloc_abort(char const * const) 	memory/mozalloc/mozalloc_abort.cpp
1 	xul.dll 	xul.dll@0xcf3970 	
2 	xul.dll 	xul.dll@0x700c93 	
3 	xul.dll 	xul.dll@0x5327bd 	
4 	xul.dll 	xul.dll@0x190797 	
5 	xul.dll 	xul.dll@0x1ae01d 	
6 	mozjs.dll 	js::Invoke(JSContext *,JS::CallArgs,js::MaybeConstruct) 	js/src/jsinterp.cpp
7 	mozjs.dll 	js::Invoke(JSContext *,JS::Value const &,JS::Value const &,unsigned int,JS::Value *,JS::Value *) 	js/src/jsinterp.cpp
8 	mozjs.dll 	js::Shape::set(JSContext *,JS::Handle<JSObject *>,JS::Handle<JSObject *>,bool,JS::MutableHandle<JS::Value>) 	js/src/vm/Shape-inl.h
9 	mozjs.dll 	js_NativeSet(JSContext *,JS::Handle<JSObject *>,JS::Handle<JSObject *>,JS::Handle<js::Shape *>,bool,JS::MutableHandle<JS::Value>) 	js/src/jsobj.cpp
10 	mozjs.dll 	js::baseops::SetPropertyHelper(JSContext *,JS::Handle<JSObject *>,JS::Handle<JSObject *>,JS::Handle<int>,unsigned int,JS::MutableHandle<JS::Value>,int) 	js/src/jsobj.cpp
11 	mozjs.dll 	js::SetPropertyOperation(JSContext *,unsigned char *,JS::Handle<JS::Value>,JS::Handle<JS::Value>) 	js/src/jsinterpinlines.h
12 	mozjs.dll 	js::Interpret(JSContext *,js::StackFrame *,js::InterpMode,bool) 	js/src/jsinterp.cpp
13 	mozjs.dll 	js::RunScript(JSContext *,js::StackFrame *) 	js/src/jsinterp.cpp
14 	mozjs.dll 	js::Invoke(JSContext *,JS::CallArgs,js::MaybeConstruct) 	js/src/jsinterp.cpp
15 	mozjs.dll 	js::Invoke(JSContext *,JS::Value const &,JS::Value const &,unsigned int,JS::Value *,JS::Value *) 	js/src/jsinterp.cpp
16 	mozjs.dll 	JS_CallFunctionValue(JSContext *,JSObject *,JS::Value,unsigned int,JS::Value *,JS::Value *) 	js/src/jsapi.cpp
17 	xul.dll 	xul.dll@0x1a9e98 	
18 	xul.dll 	xul.dll@0x1720c6 	
19 		@0x1 	
20 	user32.dll 	wcscpy_s 	
21 		@0x1febdc 	
22 	xul.dll 	xul.dll@0x10ab300 	
23 	nss3.dll 	PR_Lock 	nsprpub/pr/src/threads/combined/prulock.c
24 	nss3.dll 	PR_ExitMonitor 	nsprpub/pr/src/threads/prmon.c
25 	user32.dll 	CalcWakeMask 	
26 	winmm.dll 	timeGetTime 	
27 	xul.dll 	xul.dll@0x1a1aa2 	
28 	nss3.dll 	PR_Lock 	nsprpub/pr/src/threads/combined/prulock.c
29 	nss3.dll 	PR_Unlock 	nsprpub/pr/src/threads/combined/prulock.c
30 	xul.dll 	xul.dll@0x18daf9 	
31 	xul.dll 	xul.dll@0x180bee 	
32 	xul.dll 	xul.dll@0x4af27a 	
33 	xul.dll 	xul.dll@0x10a4ac0 	
34 	xul.dll 	xul.dll@0x10ab264 	
35 	xul.dll 	xul.dll@0x537fcd 	
36 	xul.dll 	xul.dll@0x538086 	
37 	xul.dll 	xul.dll@0x2b6b89 	
38 	xul.dll 	xul.dll@0x286391 	
39 	xul.dll 	xul.dll@0x2b69f1 	
40 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp
41 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
42 	firefox.exe 	__tmainCRTStartup 	f:/dd/vctools/crt_bld/self_x86/crt/src/crtexe.c
43 	ntdll.dll 	__RtlUserThreadStart 	
44 	oleaut32.dll 	OAInterlockedIncrement(long *) 	
45 	kernel32.dll 	Thread32First 	
46 	kernel32.dll 	Thread32First 	
47 	ntdll.dll 	LdrpGetShimEngineInterface 	
48 	ntdll.dll 	_RtlUserThreadStart
(Reporter)

Comment 1

5 years ago
sorry, read the ID's wrong.  This IS a beta 9 crasher.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 767343
You need to log in before you can comment on or make changes to this bug.