Crash on Selecting a profile in Linux via profile selector

RESOLVED DUPLICATE of bug 900026

Status

Core Graveyard
Profile: BackEnd
RESOLVED DUPLICATE of bug 900026
5 years ago
2 years ago

People

(Reporter: cviecco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When starting Firefox with the profile manager, FF crashes after the selection of any profile. Starting firefox with the named profile will no crash.

firefox -no-remote -P // plus later selection -> crash
firefox -no-remote -P $PROFILE_NAME  // OK

Here is a backtrace:
#0  0x00007f26ffddb84d in nanosleep () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f26ffddb6ec in __sleep (seconds=0) at ../sysdeps/unix/sysv/linux/sleep.c:138
#2  0x00007f26f7e8f1fe in ah_crap_handler (signum=11) at /home/cviecco/hg/mozilla-central-unified/toolkit/xre/nsSigHandlers.cpp:88
#3  0x00007f26f7e9b188 in nsProfileLock::FatalSignalHandler (signo=11, info=0x7fff216cd030, context=0x7fff216ccf00)
    at /home/cviecco/hg/mozilla-central-unified/obj-ff-dbg/toolkit/profile/nsProfileLock.cpp:190
#4  <signal handler called>
#5  0x00007f26fb1e49ee in JS_ShutDown () at /home/cviecco/hg/mozilla-central-unified/js/src/jsapi.cpp:709
#6  0x00007f26fa2c3bb7 in mozilla::ShutdownXPCOM (servMgr=0x0) at /home/cviecco/hg/mozilla-central-unified/xpcom/build/nsXPComInit.cpp:776
#7  0x00007f26fa2c3540 in NS_ShutdownXPCOM (servMgr=0x7f26ffa86338) at /home/cviecco/hg/mozilla-central-unified/xpcom/build/nsXPComInit.cpp:615
#8  0x00007f26f7e7d13e in ScopedXPCOMStartup::~ScopedXPCOMStartup (this=0x7fff216cd660, __in_chrg=<optimized out>)
    at /home/cviecco/hg/mozilla-central-unified/toolkit/xre/nsAppRunner.cpp:1130
#9  0x00007f26f7e7f951 in ShowProfileManager (aProfileSvc=0x7f26ed5405b0, aNative=0x7f26ed5339a0)
    at /home/cviecco/hg/mozilla-central-unified/toolkit/xre/nsAppRunner.cpp:1954
#10 0x00007f26f7e811c0 in SelectProfile (aResult=0x7fff216cdf10, aProfileSvc=0x7f26ed5405b0, aNative=0x7f26ed5339a0, aStartOffline=0x7fff216ce048, aProfileName=
    0x7fff216cdf88) at /home/cviecco/hg/mozilla-central-unified/toolkit/xre/nsAppRunner.cpp:2230
#11 0x00007f26f7e85379 in XREMain::XRE_mainStartup (this=0x7fff216cdef0, aExitFlag=0x7fff216cde9e)
    at /home/cviecco/hg/mozilla-central-unified/toolkit/xre/nsAppRunner.cpp:3510
#12 0x00007f26f7e87129 in XREMain::XRE_main (this=0x7fff216cdef0, argc=3, argv=0x7fff216cf458, aAppData=0x7fff216ce0a0)
    at /home/cviecco/hg/mozilla-central-unified/toolkit/xre/nsAppRunner.cpp:3911
#13 0x00007f26f7e87496 in XRE_main (argc=3, argv=0x7fff216cf458, aAppData=0x7fff216ce0a0, aFlags=0)
    at /home/cviecco/hg/mozilla-central-unified/toolkit/xre/nsAppRunner.cpp:4128
#14 0x0000000000404be0 in do_main (argc=3, argv=0x7fff216cf458, xreDirectory=0x7f26ffa2c3c0)
    at /home/cviecco/hg/mozilla-central-unified/browser/app/nsBrowserApp.cpp:275
#15 0x000000000040502d in main (argc=3, argv=0x7fff216cf458) at /home/cviecco/hg/mozilla-central-unified/browser/app/nsBrowserApp.cpp:635
(gdb) quit

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 900026
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.