Using Thunderbird, how can one attach from command line a file containing commas (,) in its name?

RESOLVED DUPLICATE of bug 900117

Status

Thunderbird
OS Integration
RESOLVED DUPLICATE of bug 900117
5 years ago
5 years ago

People

(Reporter: omidlink, Unassigned)

Tracking

17 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130627185035

Steps to reproduce:

The two files ~/test test.txt and $~/test, test.txt exist. Trying to attach them from command line:
thunderbird -compose "attachment='$~/test test.txt'" works. thunderbird -compose "attachment='$~/test, test.txt'" does not work and gives a file does not exist error.


Actual results:

The file ~/test does not exist so could not be attached to the message.


Expected results:

Both files should have been attached. Attaching works when the file with comma(s) in its name is selected using Thunderbird's Attach File(s) GUI.

Note:
In Thunderbird 3+, specifying the protocol file:// is not required any more.

Both

thunderbird -compose "attachment='$HOME/test test.txt'"

and

thunderbird -compose "attachment='file://$HOME/test test.txt'"

work.

Neither

thunderbird -compose "attachment='$HOME/test, test.txt'"

nor

thunderbird -compose "attachment='file://$HOME/test, test.txt'"

works.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 900117
You need to log in before you can comment on or make changes to this bug.