zffos1.1 when we use two or three apps in the same time, the caculater will be firstly killed? Is there some rules?

RESOLVED INCOMPLETE

Status

Firefox OS
Gaia
RESOLVED INCOMPLETE
5 years ago
5 years ago

People

(Reporter: ji.chen5, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; CIBA; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; InfoPath.2; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; TCO_20130801093201)

Steps to reproduce:

I have confirm the promblem, and doubt whether this appearance is caused by priority between different apps.
(Reporter)

Updated

5 years ago
Blocks: 899451
(Reporter)

Comment 1

5 years ago
Steps to reproduce:

1. Open the caculater
2. Do some operations,let some numbers stay on the screen.
3. Open some other app without close the caculater.
4. Do some operations
5. return to the caculater,there is no numbers anymore.

Comment 2

5 years ago
leo+ requested per bug 899451.
blocking-b2g: --- → leo?
blocking-b2g: leo? → -
Justin - Wasn't there an existing bug filed for improving priority management on which apps get killed first?
Flags: needinfo?(justin.lebar+bug)
Yeah, bug 822325.  But that is too risky, in my opinion, for 1.1.  We've had a lot of regressions every time we've changed the behavior of that code, and in particular that patch may make it so we can keep fewer apps loaded at the same time.

I don't understand why this should block.
Flags: needinfo?(justin.lebar+bug)
Okay. I'm duping this bug against that bug then, as that bug intends to solve the problem indicated in this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 822325

Updated

5 years ago
No longer blocks: 899451
Before we dupe this, can we get some data from our partners about what exactly they would like to happen in this situation?  Do they want bug 822325's behavior, or something else?  If we can do something easier/safer than bug 822325, that would be worth considering.

Ji Chen, could you please clarify?

Can someone also please clarify what blocking bug 899451 means?  When we duped this bug to bug 8322325, that bug was leo-'ed.  I don't know what it means to be leo- but blocking a release that will use 1.1.
Blocks: 899451
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(ji.chen5)
Flags: needinfo?(bbajaj)
Resolution: DUPLICATE → ---
Hi

(In reply to Justin Lebar [:jlebar] (limited availability 8/9 – 8/12) from comment #6)
> Do they want bug 822325's behavior, or something else?  
> If we can do something easier/safer
> than bug 822325, that would be worth considering.
> Ji Chen, could you please clarify?
IMHO, we should prioritize some apps above others, no matter when they were opened (such as Dialer), and an app that was invoked by other (like Browser being opened by a link in Twitter) shouldn't kill the origin. However I see there is a long discussion about this topic in bug 822325, you maybe we should just close this bug and follow the conversation over there. Anyway I will contact my colleague Ji Chen off line so that he gives their feedback. 

> Can someone also please clarify what blocking bug 899451 means?  
This is a meta bug that collects all issues considered by ZTE as blocking for our next commercial version based on FFOS V1.1

BR
> Anyway I will contact my colleague Ji Chen off line so that he gives their feedback. 

Okay.  In the meantime, let's call this bug resolved; feel free to re-open it if you guys can articulate what you think the behavior should be, and we can discuss then.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INCOMPLETE

Updated

5 years ago
Flags: needinfo?(bbajaj)
(Reporter)

Comment 9

5 years ago
Hi:

  I have test the bug on latest version, it's no longer reproduced. The caculator works well.

  Thank you.
Flags: needinfo?(ji.chen5)
You need to log in before you can comment on or make changes to this bug.