mochitest: ReferenceError: gApp is not defined from nsBlocklistService.js:768

RESOLVED DUPLICATE of bug 897031

Status

Testing
Mochitest
RESOLVED DUPLICATE of bug 897031
4 years ago
4 years ago

People

(Reporter: MattN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It seems like the blocklist service isn't disabled in mochitest-a11y as I just hit this failure:
19:34:39     INFO -  System JS : ERROR jar:file:///C:/slave/test/build/application/firefox/omni.ja!/components/nsBlocklistService.js:70
19:34:39     INFO -                       NS_ERROR_XPC_GS_RETURNED_FAILURE: Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]
19:34:39     INFO -  System JS : ERROR jar:file:///C:/slave/test/build/application/firefox/omni.ja!/components/nsBlocklistService.js:768
19:34:39     INFO -                       ReferenceError: gApp is not defined

We can possibly just disable blocklist checking with extensions.blocklist.enabled in these mochitests like we do for reftests.
Log: https://tbpl.mozilla.org/php/getParsedLog.php?id=26001909&tree=UX
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
this seems to become more a perma-orange on the trees.
Comment hidden (Treeherder Robot)
This is just log spam (now that the TBPL parser is picking this up too), it's not causing the runs to fail (but yeah it's still annoying me too!) :-)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 897031
(Note this occurs on green runs too, see bug 897031 comment 0 :-))
You need to log in before you can comment on or make changes to this bug.