Marketplace app in Firefox OS triggers text autocorrect when typing a search

RESOLVED WORKSFORME

Status

Marketplace
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Toni Hermoso Pulido, Unassigned)

Tracking

x86_64
Gonk (Firefox OS)
Points:
---

Details

(Reporter)

Description

4 years ago
I guess this is in 'Fireplace'.
When typing some text in 'Search' field, autocorrect is triggered. I would rather disable autocorrect in that field, since it makes difficult to search for things (such as brands) if automatic correction is enabled in keyboard settings.
(Reporter)

Updated

4 years ago
Component: Integration → General

Comment 1

4 years ago
I can't reproduce this in the Marketplace app on my Keon.

We are presently defining the search box as follows:

<input id="search-q" class="query-input" type="search" name="q" title=""
    autocapitalize="off" autocomplete="off" autocorrect="off" placeholder="Search" required
    value="">

You can see that we specify that we are explicitly requesting that the platform does not autocorrect, autocomplete, or otherwise gum up the search box. If that's not being respected, it sounds more like a platform issue. If you are able to reproduce it, I'd encourage you to file a bug against Gaia or B2G. If you can provide details on how/where it's happening, I can perhaps provide a pared-down test case.

It's also possible that the attributes to disable these features were implemented in a version of Gecko newer than 18.0, which would mean that it won't be implemented until Firefox OS 1.2 comes out.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
Hi Matt,
I'm experiencing this in 18.1.
Unagi built with Branch v1-train
You need to log in before you can comment on or make changes to this bug.