[zffos1.1][SMS]Image always cannot be attached into multimedia message.

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: zhang.ruili, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36

Steps to reproduce:

1. Launch and compose a new message.
2. Select an image(>500KB) from gallery.
3. Crop the image and select ok.


Actual results:

It returns to compose UI from crop UI directly, but the cropped image does not display in attachment area. This issue occurs not every time, but always.


Expected results:

The selected image should be in attachment area.
(Reporter)

Updated

5 years ago
Depends on: 899451
(Reporter)

Updated

5 years ago
Severity: normal → critical

Updated

5 years ago
Blocks: 899451
No longer depends on: 899451
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
Can we get some idea of devices and reproducibility here on current builds?
Keywords: qawanted
blocking-b2g: leo? → leo+
On my Inari, with branch master (up to date), I'm getting b2g restarting ...

I can't get any significant log, whether it crashes or gets OOM killed, but I'd bet for the first one.
Also when playing with the cropping UI, I'm seeing those in dmesg:

<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66538000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x6654b000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66552000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x6655c000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66565000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66570000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66587000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665c6000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665bf000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665b7000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665ad000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665a6000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665a0000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66597000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x6658f000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66587000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x6657b000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x6656f000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66538000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665c4000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665b4000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x665a1000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66593000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66583000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66574000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66562000 pt=0 op=READ axi=7
<2>[08-05 13:56:15.996] kgsl kgsl-3d0: |kgsl_gpummu_pagefault| mmu page fault: page=0x66554000 pt=0 op=READ axi=7
<4>[08-05 14:01:16.774] [1981: Gallery]select 2043 ((Preallocated a), adj 6, size 5522, to kill
<4>[08-05 14:01:16.774] [1981: Gallery]send sigkill to 2043 ((Preallocated a), adj 6, size 5522

Comment 5

5 years ago
Unable to verify this issue on Unagi V1.1, Leo V1.1, Buri V1.1 devices. 
Every time when an image (>500kb) is chosen from the "Gallery", image is previewed 
in the attachment

Unagi
Environmental  Variables:
Build ID: 20130805071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 45f6a739b09292e16717fb21003386c914ca29c2
Platform Version: 18.1

Leo
Environmental  Variables:
Build ID: 20130805071207
Firmaware revision: D300f080
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 45f6a739b09292e16717fb21003386c914ca29c2
Platform Version: 18.1

Buri

Environmental  Variables:
Build ID: 20130805071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 45f6a739b09292e16717fb21003386c914ca29c2
Platform Version: 18.1
RIL Version: 01.01.00.019.180
Keywords: qawanted
This reminds me of a similar bug a while ago, what version are you using ?
Flags: needinfo?(zhang.ruili)
(Reporter)

Comment 7

5 years ago
We update gecko and gaia this week and device version is being builded. We'll test it next week.
Now the gecko version is 70e86369a5c5068a8c4934b4af2fca65d70340de, gaia is 45f6a739b09292e16717fb21003386c914ca29c2. Such version has included your codes for the similar bug?
Flags: needinfo?(zhang.ruili)
(Reporter)

Comment 8

5 years ago
The bug should be closed, I think. It is not reproduced in latest version.

Comment 9

5 years ago
Since it cannot be reproduce in the latest version, I close the bug with resolved worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.