move EXPORT_NAMESPACES to mozbuild (dependency for export)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: joey, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Blocks: 847009
I think the only remaining instance of this is mfbt/exported_headers.mk, which is shared by mfbt and js/src. It looks like the line in ipc/nfc/Makefile.in can be removed since the moz.build file already has namespace information.

Is that all this bug is supposed to cover or is there something in the backend as well?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 870401
(Reporter)

Comment 3

5 years ago
(In reply to Michael Shal [:mshal] from comment #1)
> Is that all this bug is supposed to cover or is there something in the
> backend as well?

The variable is also mentioned in ipc/nfc:

./ipc/nfc/Makefile.in
  EXPORTS_NAMESPACES = mozilla/ipc
./mfbt/exported_headers.mk
  EXPORTS_NAMESPACES += mozilla
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

5 years ago
(In reply to Joey Armstrong [:joey] from comment #3)
> (In reply to Michael Shal [:mshal] from comment #1)
> > Is that all this bug is supposed to cover or is there something in the
> > backend as well?
> 
> The variable is also mentioned in ipc/nfc:
> 
> ./ipc/nfc/Makefile.in
>   EXPORTS_NAMESPACES = mozilla/ipc
> ./mfbt/exported_headers.mk
>   EXPORTS_NAMESPACES += mozilla

ps>  Need to give more than 10 minutes for a response to questions before marking bugs as a dup...
(Reporter)

Updated

5 years ago
Depends on: 870401
(Reporter)

Comment 5

5 years ago
./ipc/nfc/Makefile.in was removed elsewhere, closing the bug.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.