bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Marketplace not starting after killing it.



Firefox OS
5 years ago
22 days ago


(Reporter: tauzen, Unassigned)


Firefox Tracking Flags

(Not tracked)



(3 attachments)



5 years ago
Created attachment 784605 [details]

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

On Alcatel launch device, happens at random. Didn't see this on Unagi.   
1. Searched for twitter in Markeplace
2. Got results, went to home screen and killed the app
3. Started Marketplace 

Actual results:

Marketplace is not loading at all. Blank screen is visible. See screenshot.

Expected results:

Marketplace should load normally.

Comment 1

5 years ago
Created attachment 784607 [details]

logcat output
what do you mean by killed the app? you clicked the X from the switcher view? I don't see any explanations in the logcat. It looks like the system app is not fully loading the Marketplace maybe.

Comment 3

5 years ago
The yule log wrapper is loading, but the iframe to the marketplace is failing to load. This looks like a network connection issue.

Comment 4

5 years ago
Yes I clicked X in switcher view. 

Got this replicated a while ago after doing Marketplace update. I've done update over WiFi, switched back to 3G and accessed Marketplace - got blank page again. Killed the app and tried again, same blank screen. I've checked if other pages were loading through browser and they were. Once more i've check Marketplace and still blank screen. I've been waiting for while between every action. I had to switch to WiFI and once again kill the app. After that Marketplace was finally loading properly.

Not sure but from my perspective it looks like there some really strict timeout rules for waiting for the response. I haven't seen something like that on Unagi device on 3G. 
Or maybe this is related to some modem/hardware issues on Alcatel devices. I've observed similar behaviour with other apps.

Comment 5

5 years ago
Created attachment 784873 [details]
markeplace not starting after update

Log from the situation describe above. Though not complete, I've stopped logging after getting the blank screen after killing the app (i think).

Comment 6

5 years ago
I'm seeing a CSP error in the logs:

[JavaScript Error: "CSP ERROR:  Nie udaBo si przetworzy nieprawidBowego zródBa 'unsafe-inline']

Not sure if that's related, but it happens immediately after the Marketplace page loads.

Comment 7

5 years ago
Can someone CC some platform guys to help take a look at this? We don't specify a CSP on marketplace.firefox.com, and there's nothing in our code that would explicitly trigger the CSP (evidenced by the app working fine on all other builds of B2G/gaia).

Perhaps something is misconfigured in the version of Gaia that Alcatel is shipping?
jsmith, per comment #6 and comment #7, could you advise on how to proceed if this looks like a platform issue?
Interesting logcat points from the log summarized below.

In both logs, I'm seeing this multiple times:

E/GeckoConsole(  572): [JavaScript Error: "NS_ERROR_INVALID_POINTER: Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIContentFrameMessageManager.content]" {file: "chrome://global/content/BrowserElementChildPreload.js" line: 205}]

Following that error, I saw in one case presence of a XPCOM shutdown:

I/GonkMemoryPressure(  502): Observed XPCOM shutdown.
I/GonkMemoryPressure(  502): shutting down (1)

I see a reference error on the homescreen in the 2nd logcat:

E/GeckoConsole(  420): [JavaScript Error: "ReferenceError: Applications is not defined" {file: "app://homescreen.gaiamobile.org/gaia_build_defer_index.js" line: 5}]

And I'm seeing the CSP errors and warning Matt cites:

E/GeckoConsole(  584): [JavaScript Error: "CSP ERROR:  Nie udaBo si przetworzy nieprawidBowego zródBa 'unsafe-inline'
E/GeckoConsole(  584): "]
E/GeckoConsole(  584): [JavaScript Warning: "CSP WARN:  Nie udaBo si przetworzy nierozpoznanego zródBa 'unsafe-inline'
E/GeckoConsole(  584): "]
The first error points to code Fabrice worked on.

Fabrice - Any ideas on what's not working here?

Note - This affects 1.01 on the Alcatel device.
Flags: needinfo?(fabrice)
These all looks like cases where the Marketplace app is killed because of some memory pressure issue. Were you running other apps at the same time?
Flags: needinfo?(fabrice)

Comment 12

5 years ago
Krzysztof just messaged me, he can't update the bug but he said he he wasn't running anything else at the time
Component: General → Gaia
Product: Marketplace → Boot2Gecko
Version: 1.0 → unspecified

Comment 13

5 years ago
Anybody working on this? I just got it few minutes ago. First I bumped into bug 900567. I've submited a marketplace log in here: https://bugzilla.mozilla.org/show_bug.cgi?id=900567#c4. After that I've closed the app with going to card view and pressing 'x'. I see blank screen now when trying to start marketplace. I didn't have any other applications running before.
Severity: normal → major
Priority: -- → P1

Comment 14

22 days ago
Firefox OS is not being worked on
Last Resolved: 22 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.