iCal issues, unable to add events to shared calendars

RESOLVED FIXED

Status

Infrastructure & Operations Graveyard
Infrastructure: Zimbra
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: hlangi, Unassigned)

Tracking

other
x86
Mac OS X
Bug Flags:
pending-upstream-fix +

Details

(Whiteboard: [Zimbra 00115305])

(Reporter)

Description

4 years ago
Unable to add events to shared zimbra calendars on ical.

Followed instructions online to set the default calendar to last selected. Once selecting a shared calendar and clicking to create an event, we get the following error:

You can't change events or reminder in "Shared Calender Name" calendar.
Only the calendar administrator and any delegates with permission can make changes to read-only calendars. To make changes to the calendar, contact the calendar administrator.

We're able to create events on shared calendars in zimbra.

Looks like a known issue with osx 10.7 https://discussions.apple.com/thread/3190393?start=0&tstart=0
(Reporter)

Comment 1

4 years ago
I have Chenxia CCed on here and confirmed that she was able to update shared calendars on iCal a few weeks ago but only noticed there was an issue recently. Also, Peter is on osx 10.8 and seemed to have also lost that functionality as well.
I confirmed this behavior in both iCal and BusyCal. I filed a support ticket with Zimbra.
Flags: pending-upstream-fix+
Whiteboard: [Zimbra 00115305]
Assignee: desktop-support → justdave
Component: Server Operations: Desktop Issues → Infrastructure: Zimbra
Product: mozilla.org → Infrastructure & Operations
QA Contact: tfairfield → justdave
Just to confirm, this is NOT the same problem that Apple Discussions thread was about.  That one was similar, but was an actual bug in iCal itself, which has long since been fixed.  This one is definitely a problem with Zimbra.

From the discussion on Zimbra's bug it sounds like they were attempting to prevent people from causing accidental damage, and went overboard.
Has anyone been able to replicate this on anything other than iCal or BusyCal?  Need data to give Zimbra.
Flags: needinfo?(henry)
(Reporter)

Comment 5

4 years ago
iCal is probably the main client end-users are working with, so far those are the only two clients we're aware of that have issues.
Flags: needinfo?(henry)
I pinged on the upstream bug and the corresponding support ticket again, since there's been a lack of movement on it.
Assignee: justdave → infra
QA Contact: justdave → limed
Got a response back on the upstream bug:

-----8<-----
Could you answer a few questions for me please:
1.  What version of Zimbra are you using?
2.  For the Calendar admins, has the setting
       "Enable delegation for Apple iCal CalDAV client"
    been enabled or not?  This is configurable via the Web Client's Preferences
    in the Calendar section.
3.  Would it be possible to see a trace of the CalDAV traffic?  BusyCal may
    be useful for this, under "Help", "Show Logs".
4.  Could you provide any snippets from mailbox.log related to the issue.
5.  You mention that admins are unable to create new appointments.  Are they
    able to update them?
6.  Are the shared calendars on the same Zimbra server?
    If not, are the versions of Zimbra on the different servers the same?

I've just been trying to reproduce the issue using BusyCal.
With "Enable delegation for Apple iCal CalDAV client" disabled, the shared
calendars are regarded as read only (and indicated as such in BusyCal).
With the setting enabled, I was able to create new meetings and update old ones
successfully.  I am seeing an issue with iTip messages created for updates to
old meetings, where they are not accepted as proper updates by ZWC, but I
suspect that isn't your issue.
-----8<-----
OK, they've reproduced the problem we're hitting, and it turns out to be not related to the bug we've been discussing it on, so it's been split off to a new bug upstream.
But the short version is that to edit a shared calendar via CalDAV requires "Enable iCal delegation model" to be enabled in your preferences in the Zimbra web client.  Which will in turn completely hide your shared calendars from anything that's not an iDevice (device manufactured by Apple). So editing shared calendars via CalDAV is essentially limited to iDevices right now.
I just tried enabling "iCal delegation model" from my Zimbra webclient preferences, and this simply made the shared calendar disappear from my local iCal (running on a Macbook Pro). Disabling this preference made the calendar reappear; still without local editing privileges in iCal.
After enabling delegation, did you subscribe to the calendar in iCal's settings for that account?
This was fixed in Zimbra 8.0.6, which we are currently running.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.