Restart message does not appear when selecting Japanese UI or locale

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: jonrubin, Assigned: tao)

Tracking

({intl})

Trunk
mozilla0.9.5
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This bug will be invalid if bug 66909 is resolved; however, 66909 is currently
marked as Future.

Found on WinMe-Ja using 07-07-12-branch build.  

Steps:

1) Create a new profile that is set to the default language and region, i.e. en-US.
2) If necessary, go to View>Set Language/Region>Download More and download
Japanese language and content packs.
3) Select Japanese language or region in the View menu.  The restart message
does not appear.
(Reporter)

Comment 1

17 years ago
Note that after restart, if US region or English is selected, the restart
message appears.
Keywords: intl
QA Contact: andreasb → jonrubin

Comment 2

17 years ago
add jbetak to the cc list. jbetak recently check in something for the message so
we won't show the messge when user select the download more menu. jbetak, please
take a look a this one. Is this related ?
hmm, this might have to do with the switch from simple alert() to prompt 
service...
jon, I agree there seems to be some problem with the 07-07-12 build. However, I 
just pulled a 07-11-12 build the problem seems to be resolved there. Could you 
please confirm? 

I'm still investigating, what happened between 07/07 and 07/11
OK, this is not related to any changes from 'alert()' to prompt service or my 
June 29 checkin for bug 87535.

I just checked the 07-07-12 build and the chrome registry is throwing an 
exception, when we attempt to switch to a 6.1 commercial language pack (I 
tested with DE and JA). We are then assuming that the locale switch didn't 
occur and don't display the restart notification.

This exception doesn't get thrown with a more recent branch build. I'm still 
looking for the checkin, which fixed this... 
cc'ing tao and hyatt for recent (07-07 to 07-11) branch chrome registry changes 
(Assignee)

Comment 7

17 years ago
Are we not removing those menuitems from the View menu? -> 0.9.3
Target Milestone: --- → mozilla0.9.3
good point! Although, I thought we (i18n at least) wanted to keep them there if 
possible to maintain high visibility...

Nevertheless, we have a similar issue with the pref panels. The restart alerts 
don't come up at all, when requesting the locale switch there.

Also please note, that this bug no longer occurs in recent branch builds. (jon 
could you please confirm that?) So, this is a mere academic attempt to find 
out, what keeps breaking.
(Reporter)

Comment 9

17 years ago
Juraj,

You are correct--I just confirmed on 07-11-branch build (on WinXP-Ja) that the
bug does not occur.  Do you want to resolve this as Worksforme, or continue your
investigation of what keeps breaking to avoid a regression?
(Assignee)

Comment 10

17 years ago
non-stoppers -> 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 11

17 years ago
mass change, switching qa contact from jonrubin to ruixu.
QA Contact: jonrubin → ruixu
(Assignee)

Comment 12

17 years ago
->0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Comment 13

17 years ago
Couldn't reproduce on 2001-10-02-0.9.4 build.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 14

17 years ago
Verify fixed with 2001-10-02 JA build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.