Stop words are still highlighted in search result summaries

RESOLVED DUPLICATE of bug 900869

Status

support.mozilla.org
Search
--
minor
RESOLVED DUPLICATE of bug 900869
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
It's a follow-up of bug 894686. Prod and staging servers have been compared.

If you type a stop word, it's removed for the search (great!) but it's still highlighted in search result summaries. It shouldn't to make it clear it wasn't used.
https://support.mozilla.org/fr/search?q=ne+firefox&esab=a&product=firefox&w=1 and https://support.allizom.org/fr/search?q=ne+firefox&esab=a&product=firefox&w=1
I don't know enough about the psychology of reading search results to say whether it's better to highlight the stop word even though it wasn't used or not. I'm pretty sure though that normal users will not infer anything from the highlights. I'm pretty sure that they won't be able to tell that we didn't use the stop word in search, just because we don't highlight it. 

On the other hand, Google highlights stopwords that weren't used, and they know a thing or two about the psychology of reading search results. Not that we should blindly follow them of course.

So, I'm inclined to leave it as it is. Unless we have a good reason to remove that highlight.
I agree with Kadir here. Stop words are not completely discarded from the search query, and a user might not realize that they are being de-emphasized in the query, so I think they should be highlighted where they appear.
(Reporter)

Comment 3

5 years ago
I want the same feature as in English. See https://support.mozilla.org/en-US/search?w=1&product=firefox&q=this+is+Firefox where this and is are not in bold.
Ah, I didn't know that is how English behaved. This probably has the same root cause as bug 900869, so I'm going to make this block on that. If fixing that bug doesn't have an affect here, we can revisit.
Depends on: 900869
Now that I have worked on it a bit, I know that this is the exact same problem as bug 900869, so marking it as a dupe.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 900869
You need to log in before you can comment on or make changes to this bug.