Closed Bug 900870 Opened 9 years ago Closed 9 years ago

[Settings] Register new event handlers of BluetoothAdapter

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gyeh, Assigned: arthurcc)

References

Details

Attachments

(1 file)

Several system messages are going to be removed. Instead of binding message handler, new event handlers should be registered.

The following cases should be covered:
* bluetooth-pairedstatuschanged -> adapter.onpairedstatuschanged
* bluetooth-hfp-status-changed -> adapter.onhfpstatuschanged

The event consist of two properties:
- event.address
- event.status
Depends on: 853221
Summary: Register new event handlers of BluetoothAdapter → [Settings] Register new event handlers of BluetoothAdapter
Blocks: 900874
No longer blocks: 900874
Blocks: 900880
This has been landed with bug 900874.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 900874
bluetooth-pairedstatuschanged is not replaced by the patch of bug 900874. Reopen this bug. Gina, thanks for reminding.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → arthur.chen
Oops! I missed that one in the bug description. :|

The new event handler is 'onpairedstatuschanged'.
Evelyn, could you help review this change? Thanks!
Attachment #797106 - Flags: review?(ehung)
Comment on attachment 797106 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11829

r=me, thanks.
Attachment #797106 - Flags: review?(ehung) → review+
Thanks!

master: https://github.com/mozilla-b2g/gaia/commit/420a0727b8c7ff2ba1f42a790d93518643a6868b
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.