[System] Register new event handlers of BluetoothAdapter

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: gyeh, Assigned: arthurcc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Several system messages are going to be removed. Instead of binding message handler, new event handlers should be registered.

The following cases should be covered:
* bluetooth-hfp-status-changed -> adapter.onhfpstatuschanged
* bluetooth-sco-status-changed -> adapter.onscostatuschanged

The event consist of two properties:
- event.address
- event.status
(Reporter)

Updated

5 years ago
No longer depends on: 900870
(Reporter)

Updated

5 years ago
Blocks: 900880
Assignee: nobody → arthur.chen
Created attachment 787427 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11423

Evelyn, could you help review the change? I've done some basic tests and it worked as expected. Thanks!
Attachment #787427 - Flags: review?(ehung)

Comment 2

5 years ago
Comment on attachment 787427 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11423

r=me with a nit addressed. Thanks!
Attachment #787427 - Flags: review?(ehung) → review+
Comment addressed. Thanks for reviewing!

master: https://github.com/mozilla-b2g/gaia/commit/f401f46388588aff4d259b4f2559d1f4cb9aa6f5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Duplicate of this bug: 900870
Comment hidden (typo)
Comment hidden (typo)
Comment hidden (typo)
Comment hidden (typo)
You need to log in before you can comment on or make changes to this bug.