Unclosable tab when two Firefox are launched successively

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: myopenid, Unassigned)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 784904 [details]
ss.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130801 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130801030223

Steps to reproduce:

1. Triple click firefox icon to launch two firefox successively.
2. Open new tab in second launched firefox.
3. Close tab by pressing x / Close tab through context menu.


Actual results:

Cannot close tab, context menu missing Undo Close Tab.


Expected results:

Tab close on x click, context menu should have Undo Close Tab.
(Reporter)

Updated

4 years ago
Component: Untriaged → Tabbed Browser

Comment 1

4 years ago
You cannot open 2 identical Firefox successively, without having a dialog box saying FF is already running.
(Reporter)

Comment 2

4 years ago
No dialog. When I triple click firefox icon, two Windows appeared. Want a video?

Comment 3

4 years ago
Could you test with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Maybe you will need to use the command line -profile "profile_path" (-no-remote) for the desktop shortcut, see https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options
Flags: needinfo?(myopenid)
(Reporter)

Comment 4

4 years ago
Started afresh with new profile. Same thing.

Though not a serious bug. This only happens if there is no firefox running, and open two new firefox consecutively.

I don't know but I'm just guessing that perhaps the profile was in 'read-only' mode when the first window is opened, causing the second window to fail to read.
Flags: needinfo?(myopenid)
I'm unable to reproduce this with a clean profile. 
I get the "Firefox is already running" dialog if I triple click.

Tried with latest Nightly (build ID:20130813155809)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Could you please try to see if this reproduces for you with the latest nightly build?
Flags: needinfo?(myopenid)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:27.0) Gecko/20100101 Firefox/27.0
Build ID: 20130922030201

Marking as WFM.

If someone is able to reproduce this, please reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(myopenid)
You need to log in before you can comment on or make changes to this bug.