The background-color of the first option is not shown in the <select>-list

RESOLVED DUPLICATE of bug 79107

Status

()

RESOLVED DUPLICATE of bug 79107
18 years ago
17 years ago

People

(Reporter: phil, Assigned: rods)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
- Option-Color-Bug:
Description: The background-color of the first option is not shown in the
<select>-list
Phil, please read the bug reporting guidelines at
http://www.mozilla.org/quality/bug-writing-guidelines.html, and try to use the
Bugzilla Helper (http://www.mozilla.org/quality/help/bug-form.html) to report
bugs -- it prompts your for all the necessary information.

At the very least, a clear description of the problem and a build ID on which
you're seeing the problem are needed.  A testcase or demonstration would be very
helpful.
(Reporter)

Comment 2

18 years ago
Mozilla 0.9.2 (Build ID: 2001062815) on WinNT4:

Description: The color of the first option is not shown in the list - the other 
work: In the example below the background-color of "Chromium" is not displayed - 
background-colors from "Cobalt" (second entry) to "Titanium" (last entry) do 
work.

<select>

<option value="Chromium" style="background:#9CB2A5; 
color:black">Chromium</option>

<option value="Cobalt" style="background:#9C9EBD; color:black">Cobalt</option>

<option value="Iridium" style="background:#AD929C; color:black">Iridium</option>

<option value="Titanium" style="background:#BDBAB5; 
color:black">Titanium</option>

</select>

Please see http://www.goli.at/phil/mozilla/bugs.html - it's all there
Linux build 2001-07-06-08 -- all colors show fine (except the selected option is
blue, of course).

Comment 4

18 years ago
Win98: all of the colors display when I drop down the select list, but the 
background of the select is always white when the menu isn't visible and when 
the select doesn't have focus.  The first item doesn't seem special.
Philipp, could you attach a screenshot of the expected rendering? Or at least
describe it in more detail?
(Reporter)

Comment 6

17 years ago
added a screenshot at the end of the 
page: http://www.goli.at/phil/mozilla/bugs.html
Created attachment 42423 [details]
expected rendering
I see the same behavior on Linux as Jesse does on win98 -- the closed select is
always white.  The colors show fine in the dropdown menu.  Over to HTML form
controls.... I'm not convinced this is a bug.
Assignee: karnaze → rods
Status: UNCONFIRMED → NEW
Component: HTML Element → HTML Form Controls
Ever confirmed: true
QA Contact: amar → madhur

Comment 9

17 years ago

*** This bug has been marked as a duplicate of 79107 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.