[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://browser/content/aboutDialog.js :: init :: line 14" data: no]

VERIFIED FIXED in Firefox 28

Status

()

Firefox
General
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: rstrong)

Tracking

({regression})

unspecified
Firefox 28
x86_64
All
regression
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox22 unaffected, firefox23-, firefox24-, firefox25-, firefox28 verified, firefox-esr24- wontfix)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/05d3797276d3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130801 Firefox/25.0 ID:20130801030223


Steps To Reproduce:
1. Alt > Tools > About Nightly

Actual Results:
An error shous in Browser Console
--
[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://browser/content/aboutDialog.js :: init :: line 14"  data: no] @ chrome://browser/content/aboutDialog.js:32

Expected Results:
No error.



Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b41552ecce1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130719 Firefox/25.0 ID:20130719131550
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1273e2556a0f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130719 Firefox/25.0 ID:20130719131750
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6b41552ecce1&tochange=1273e2556a0f


Regressed by:
1273e2556a0f	Robert Strong — Wallpaper fix - Bug 895473 - [Mac and Linux] Custom distribution settings for yahoo de and es distributions are not being set. r=mconnor
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
mconnor, this is caused by adding the report error as you requested in bug 895473 comment #4
Mike, given comment #1 what do you want to do with this?
Flags: needinfo?(mconnor)
In theory I'm on PTO, won't be around to see replies.

This is just reporting the error that's getting caught, I assume, so it's not impeding functionality, so other than perhaps fixing the underlying cause I see little cause for concern.

Previously this would have meant bustage, now we're just catching and reporting the error, thus I do not believe this should block anything.
Flags: needinfo?(mconnor)
tracking-firefox23: ? → -
tracking-firefox24: ? → -
tracking-firefox25: ? → -

Updated

5 years ago
Summary: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://browser/content/aboutDialog.js :: init :: line 1 → [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: chrome://browser/content/aboutDialog.js :: init :: line 14" data: no]
Created attachment 8334378 [details] [diff] [review]
patch rev1

Mike, I removed the reportError that was added so it is the same as it was previously and added a new try catch so only the actual issue will be reported.
Attachment #8334378 - Flags: review?(mconnor)
Comment on attachment 8334378 [details] [diff] [review]
patch rev1

Looks good.  With the try/catch, the comment feels slightly untrue, but meh. [1]

[1] https://twitter.com/iamdevloper/status/397664295875805184
Attachment #8334378 - Flags: review?(mconnor) → review+
Created attachment 8335677 [details] [diff] [review]
patch as pushed with updated comment
Assignee: nobody → robert.bugzilla
Attachment #8334378 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8335677 - Flags: review+
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/74872a1388ef
Flags: in-testsuite-
Target Milestone: --- → Firefox 28
Version: 23 Branch → unspecified
https://hg.mozilla.org/mozilla-central/rev/74872a1388ef
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

4 years ago
Keywords: verifyme
User Agents:
[1] Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
[2] Mozilla/5.0 (Windows NT 6.2; rv:24.0) Gecko/20100101 Firefox/24.0
[3] Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
[4] Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:24.0) Gecko/20100101 Firefox/24.0

This issue is also reproducible on Fx ESR 24.3.0 (Build ID: 20140128141233) using:
- Windows 7 64-bit [1]
- Windows 8 32-bit [2]
- Ubuntu 12.04 32-bit [3]
- Mac OS X 10.7 [4]

Comment 10

4 years ago
Verified as fixed with Firefox 28.0b3 on Mac OS X 10.7.5, Windows 7 64bit and Ubuntu 12.10 64bit.
Status: RESOLVED → VERIFIED
status-firefox28: --- → verified
status-firefox-esr24: --- → affected
tracking-firefox-esr24: --- → ?
Keywords: verifyme
This doesn't meet ESR criteria, nor is it something that the ESR community has asked to see fixed due to widespread impact, minus & wontfixing for esr branch.
status-firefox-esr24: affected → wontfix
tracking-firefox-esr24: ? → -

Updated

4 years ago
Depends on: 1002750
No longer depends on: 1002750
You need to log in before you can comment on or make changes to this bug.