java plugin gets downloaded but wont install

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
--
major
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: Bill Sirinek, Assigned: Xiaobin Lu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062823

When I go to chat.yahoo.com I am asked to install the java plugin, which is fine
since i dont have the java stuff and yahoo's chat software is java-based. So I
get a window that pops up asking me which plugin I want, Windows or Linux. I
choose Linux, the software downloads in a few mins (cable modem) and when its
down downloading, I get the following error:

Install Results
Java 2 Plug-in for Linux: Download was unsuccessful. Please try again. The Java
Plug-in is 7.6Mb and will take you 37 minutes to fully download with a 28.8
modem or 19 minutes with a 56K modem. Alternatively, you can download this
plug-in directly from our FTP site at
ftp://ftp.netscape.com/pub/netscape6/english/6.0/windows/win32/smartupdate/jre13i.exe
for Windows. Please e-mail ftp-plugins@netscape.com if you continue to have
problems. Error encountered -- -235

Reproducible: Always
Steps to Reproduce:
1. Without the java plugin installed, go to a page that needs java
2. Choose to download the linux plugin (im on debian woody linux)
3. Wait for the download to finish and install.

Actual Results:  Install Results
Java 2 Plug-in for Linux: Download was unsuccessful. Please try again. The Java
Plug-in is 7.6Mb and will take you 37 minutes to fully download with a 28.8
modem or 19 minutes with a 56K modem. Alternatively, you can download this
plug-in directly from our FTP site at
ftp://ftp.netscape.com/pub/netscape6/english/6.0/windows/win32/smartupdate/jre13i.exe
for Windows. Please e-mail ftp-plugins@netscape.com if you continue to have
problems. Error encountered -- -235

Expected Results:  Installed the plugin and let me use Java :)

Comment 1

17 years ago
==> OJI
Component: Plug-ins → OJI

Comment 2

17 years ago
I was having the same problem/error unil I remembered I had installed Mozilla as
root, therefor attempting to install the plugin as an other user would fail
since /usr/lib/mozilla is read-only.

Su'd, ran mozilla, attempted plugin install: Success.

Question: Should not a user installed plugin be installed in ~/.mozilla/plugin
or similar?

Comment 3

17 years ago
I get this too.

At the very least, the error page should be properly formatted and contain a
sensible error message (peferably something like "Couldn't get access to
necessary directory, please re-run as root and try again") The current error
page is totally unintelligible.

Should "better error reporting for failed plugin download/install" be a separate
bug report?  Even if the Java thing gets fixed, this beahvior sucks for other
plugin failures...

Comment 4

17 years ago
Xiaobin, can you please talk to AV and see if it makes sense for you to own 
this bug?

Thanks,
Ed

Comment 5

17 years ago
I think so. In fact, I meant to reassign it when I changed component.
Assignee: av → xiaobin.lu
(Assignee)

Comment 6

17 years ago
I think this is a dup of some bug which has been fixed. Please try to download
the nightly build of Mozilla and install java plugin as ROOT. Let me know if you
have problem.
(Reporter)

Comment 7

17 years ago
I downloaded nightly 2001072806 for i386 linux and the java plugin install works! Thanks! :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

17 years ago
I forgot to mention before but I submitted this error originally because I did 
install v0.92 (2001062823) and try to install java all as root and still got 
the error. But it is working now. Thanks for all your help. :)

Comment 9

17 years ago
v
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.